Bug 1357849 - OSE 3.3 one secret/keystore can not be mount to several locations
Summary: OSE 3.3 one secret/keystore can not be mount to several locations
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: openshift-controller-manager
Version: 3.3.0
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ---
: ---
Assignee: Paul Morie
QA Contact: zhou ying
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-19 12:02 UTC by Libor Fuka
Modified: 2016-09-27 09:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-27 09:41:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1933 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.3 Release Advisory 2016-09-27 13:24:36 UTC

Description Libor Fuka 2016-07-19 12:02:22 UTC
Description of problem:
The one secret (one keystore) can not be mount to several locations.
It was possible in OSE 3.2.

Version-Release number of selected component (if applicable):
OpenShift Master:
    v3.3.0.5
Kubernetes Master:
    v1.3.0+57fb9ac 

How reproducible:


Steps to Reproduce:
1. Create secret with two keystores
2. mount keystores to two different locations

Additional info:
Regression comparing to OSE 3.2

Comment 1 Paul Weil 2016-08-03 15:09:38 UTC
should be fixed in PR https://github.com/openshift/origin/pull/10111.  Moving to QA

Comment 2 Troy Dawson 2016-08-03 19:01:22 UTC
This has been merged and is in OSE v3.3.0.14 or newer.

Comment 4 zhou ying 2016-08-09 06:12:07 UTC
Confirmed with OSE3.3.0.16, the issue has fixed.
openshift version
openshift v3.3.0.16
kubernetes v1.3.0+507d3a7
etcd 2.3.0+git


[root@zhouy testjson]# oc describe secrets mysecret
Name:		mysecrets
Namespace:	zhouy
Labels:		<none>
Annotations:	<none>

Type:	Opaque

Data
====
1.txt:	19 bytes

[root@zhouy testjson]# more /home/1.txt 
password
password2

Name:		deployment-example
Namespace:	zhouy
Created:	20 minutes ago
Labels:		app=deployment-example
Annotations:	openshift.io/generated-by=OpenShiftNewApp
Latest Version:	2
Selector:	app=deployment-example,deploymentconfig=deployment-example
Replicas:	1
Triggers:	Config, Image(deployment-example@latest, auto=true)
Strategy:	Rolling
Template:
  Labels:	app=deployment-example
		deploymentconfig=deployment-example
  Annotations:	openshift.io/container.deployment-example.image.entrypoint=["/deployment","v1"]
		openshift.io/generated-by=OpenShiftNewApp
  Containers:
   deployment-example:
    Image:	openshift/deployment-example@sha256:ea9135488f323060cb18ab3ec06286cd49e4b3a611fce1a6a442651ecf421f99
    Port:	8080/TCP
    Volume Mounts:
      /opt from mysecrets (rw)
    Environment Variables:	<none>
  Volumes:
   mysecrets:
    Type:	Secret (a volume populated by a Secret)
    SecretName:	mysecrets



Name:		hello-openshift
Namespace:	zhouy
Created:	3 minutes ago
Labels:		app=hello-openshift
Annotations:	openshift.io/generated-by=OpenShiftNewApp
Latest Version:	2
Selector:	app=hello-openshift,deploymentconfig=hello-openshift
Replicas:	1
Triggers:	Config, Image(hello-openshift@latest, auto=true)
Strategy:	Rolling
Template:
  Labels:	app=hello-openshift
		deploymentconfig=hello-openshift
  Annotations:	openshift.io/container.hello-openshift.image.entrypoint=["/hello-openshift"]
		openshift.io/generated-by=OpenShiftNewApp
  Containers:
   hello-openshift:
    Image:	openshift/hello-openshift@sha256:62538b79ee7be867d0e8df3172236124671157560e38fa4fda0a6cf8cdc5a2ee
    Ports:	8080/TCP, 8888/TCP
    Volume Mounts:
      /opt from test (rw)
    Environment Variables:	<none>
  Volumes:
   test:
    Type:	Secret (a volume populated by a Secret)
    SecretName:	mysecrets

Comment 6 errata-xmlrpc 2016-09-27 09:41:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1933


Note You need to log in before you can comment on or make changes to this bug.