Bug 1357896 - GW-NFS unable to rename files between directories of the mounted fs
Summary: GW-NFS unable to rename files between directories of the mounted fs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 2.0
Hardware: All
OS: All
unspecified
low
Target Milestone: rc
: 2.0
Assignee: Matt Benjamin (redhat)
QA Contact: shylesh
URL:
Whiteboard:
Depends On: 1357932
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-19 14:02 UTC by Matt Benjamin (redhat)
Modified: 2017-07-30 15:50 UTC (History)
11 users (show)

Fixed In Version: RHEL: ceph-10.2.2-38.el7cp Ubuntu: ceph_10.2.2-30redhat1xenial
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:44:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1755 normal SHIPPED_LIVE Red Hat Ceph Storage 2.0 bug fix and enhancement update 2016-08-23 23:23:52 UTC

Description Matt Benjamin (redhat) 2016-07-19 14:02:37 UTC
Description of problem:

RGW-NFS unable to rename files between directories of the mounted fs.

How reproducible:
100%


Steps to Reproduce:
1. mount nfs-rgw (e.g., at /mnt/rgw)
2. create directories /mnt/rgw/d1 and /mnt/rgw/d2
3. create a file f1 in /mnt/rgw/d1
4. mv 

Actual results:
"file does not exist"

Expected results:
(no error)

Additional info:
This bug is already fixed on ceph upstream, creating this bz to pull to rhcs 2.0.  Since rename is performed by the rsync program, our tech preview use case requires it.

Comment 2 Neil Levine 2016-07-19 16:54:54 UTC
This doesn't have to block 2.0 if we can't merge it in time. It's TP only so these kind of bugs are acceptable until we fix in an async.

Comment 18 shylesh 2016-08-10 10:14:19 UTC
both rsync and mv tests are working

[root@magna104 mnt]# rsync -rv ~/torsync/* ./target/
sending incremental file list
file1
file2
file3

sent 31461290 bytes  received 69 bytes  8988959.71 bytes/sec
total size is 31457280  speedup is 1.00

so marking this as verified.

verified on librgw2-10.2.2-38.el7cp.x86_64

Comment 21 errata-xmlrpc 2016-08-23 19:44:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1755.html


Note You need to log in before you can comment on or make changes to this bug.