Bug 1357905 - Satellite is failing to enable EUS repositories for Resilient Storage for RHEL 5 and 6
Summary: Satellite is failing to enable EUS repositories for Resilient Storage for RHE...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Subscription Management
Version: 6.1.9
Hardware: Unspecified
OS: Unspecified
high
high vote
Target Milestone: Unspecified
Assignee: John Mitsch
QA Contact: jcallaha
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks: 1367851 1405509 Sat6_HA_Tracker
TreeView+ depends on / blocked
 
Reported: 2016-07-19 14:39 UTC by Roman Bobek
Modified: 2019-06-13 21:25 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1367851 (view as bug list)
Environment:
Last Closed: 2016-09-27 09:03:27 UTC
Target Upstream Version:


Attachments (Terms of Use)
Subscritpion manifest (457.18 KB, application/zip)
2016-08-05 07:27 UTC, Roman Bobek
no flags Details
verification screenshot (119.54 KB, image/png)
2016-09-22 18:57 UTC, jcallaha
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1938 normal SHIPPED_LIVE Satellite 6.1.10 bug fix update 2016-09-27 12:56:10 UTC
Foreman Issue Tracker 16133 None None None 2016-08-16 20:03:49 UTC
Red Hat Knowledge Base (Solution) 1305173 None None None 2016-10-03 21:28:12 UTC

Description Roman Bobek 2016-07-19 14:39:38 UTC
Description of problem:

Satellite is not able to enable following repositories:
- EUS repositories for Resilient Storage for RHEL 6
- EUS repositories for Resilient Storage for RHEL 5

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1) Create a manifest with Resilient Storage subscription attached
2) Upload the manifest to the Satellite server
3) Try to enable one of repos from:
- Red Hat Enterprise Linux Resilient Storage (for RHEL 6 Server) - Extended Update Support (RPMs)
- Red Hat Enterprise Linux Resilient Storage (for RHEL 5 Server) - Extended Update Support (RPMs)

Actual results:
Following error appears:
CDN loading error: access forbidden to https://cdn.redhat.com:443/content/eus/rhel/server/6/6Server/x86_64/resilientstorage/os/repodata/repomd.xml

Expected results:
Repository should be enabled

Additional info:
- This issue might be related to following issue with EUS for Resilient storage
https://projects.engineering.redhat.com/browse/RCM-2563
- There is manifest showing this behavior attached to the support case 01662366

Comment 3 Bryan Kearney 2016-07-26 18:54:43 UTC
Moving 6.2 bugs out to sat-backlog.

Comment 5 Roman Bobek 2016-08-04 12:43:14 UTC
Hello Barnaby,

I'm still suspicious that Satellite is not working correctly here.

There all necessary subscriptions attached to the manifest. I have even tested it by removing the subscriptions from the manifest, attaching them to the system registered directly with RHSM (no Satellite) and I have enabled EUS repositories for RS successfully.

But the Satellite is still failing to enable the RS EUS repositories.

Many thanks for your collaboration on this.

Best regards,


Roman Bobek
Associate Technical Support Engineer

Comment 6 Roman Bobek 2016-08-05 07:27:41 UTC
Created attachment 1187789 [details]
Subscritpion manifest

Comment 21 John Mitsch 2016-08-16 19:38:57 UTC
Created redmine issue http://projects.theforeman.org/issues/16133 from this bug

Comment 22 John Mitsch 2016-08-17 15:41:08 UTC
PR open here https://github.com/Katello/katello/pull/6246

Comment 23 Bryan Kearney 2016-08-19 16:16:51 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/16133 has been closed

Comment 25 Mike McCune 2016-08-26 22:44:49 UTC
Created attachment 1194518 [details]
ruby193-rubygem-katello-2.2.0.83-1.el6_6sat.git.1.8ec3716None.noarch.rpm

Comment 33 jcallaha 2016-09-22 18:56:51 UTC
Verified in Satellite 6.1.10 Snap 1.1

I am able to enabled all EUS RHEL Resilient Storage repositories for RHEL5 and 6. See attached screenshot for verification.

Comment 34 jcallaha 2016-09-22 18:57:40 UTC
Created attachment 1203888 [details]
verification screenshot

Comment 36 errata-xmlrpc 2016-09-27 09:03:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1938


Note You need to log in before you can comment on or make changes to this bug.