Bug 135802 - missing entries in libsane.usermap from sane-backends
missing entries in libsane.usermap from sane-backends
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: sane-backends (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-15 00:30 EDT by Michal Jaegermann
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-03 11:30:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2004-10-15 00:30:30 EDT
Description of problem:

Recently I got my paws on a USB scanner.  It is actually recognized
and supported by SANE 1.0.14 (and scans quite nicely).  'scanimage -L'
reports:

  device `epson:libusb:001:002' is a Epson GT-X700 flatbed scanner

This is correct.  GT-X700 is a marketting name used in Asia for
the same machine known in North America and Europe as "Perfection
4870 Photo",  The problem is that in /etc/hotplug/usb/libsane.usermap
an entry for that device does not exist and on hotplug events
/etc/hotplug/usb/libusbscanner script does not run.

Adding an entry similar to other already existing but with
"0x04b8   0x0128" for USB identfiers immediately wakes up that script.
No idea how many other such entries may be missing.

Version-Release number of selected component (if applicable):
sane-backends-1.0.14-6
Comment 1 Tim Waugh 2004-10-15 04:26:35 EDT
Could you please paste in the exact line that works for you?  Thanks.
Comment 2 Michal Jaegermann 2004-10-15 11:55:21 EDT
This is exactly what I added in libsane.usermap:

# Epson Corp.|Perfection 4870 Photo
libusbscanner             0x0003      0x04b8   0x0128    0x0000 \
       0x0000       0x00         0x00            0x00            0x00\ 
           0x00               0x00               0x00000000

with this exception that the second one is really a one long line
instead of beeing broken/joined with '\'s.  The same as with
other Epson scanners in this file; only a number in the fourth
field is different (the highest one is currently 0x011f).

The difference is that in FC2 I had to add in a config file in
/etc/sane.d a line which said

usb 0x4b8 0x128

before 'sane-find-scanner' started to react, so this was an "unknown
scanner" and an absence of a line above from libsane.usermap was not
surprising, while a version of sane used currently knows about that
hardware and a more "choosy" 'scanimage -L' reports it immediately,
but the line above is still missing in libsane.usermap.
Comment 3 Tim Waugh 2004-12-03 11:30:40 EST
Reported upstream.
Comment 4 Michal Jaegermann 2005-09-24 13:55:56 EDT
sane-backends-1.0.15-9, as supplied with FC4, are still lacking that simple entry.
It shows up as
# Epson Corp.|Perfection 4870 Photo (GT-X700)
in sane-backends-1.0.16-1, and some other similar entries too, which one can find
for the current "rawhide". Well over a year before that one-liner will be in
distributions seems like an awfully long time.  "Perfection 4870" is likely
already replaced by something else in stores.

Note You need to log in before you can comment on or make changes to this bug.