Bug 1358038 - Fix gulp ECMDERR on older node, by forcing plato to 1.4
Summary: Fix gulp ECMDERR on older node, by forcing plato to 1.4
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.5.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.5.5
Assignee: Aparna Karve
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On: 1358036
Blocks: 1358037
TreeView+ depends on / blocked
 
Reported: 2016-07-19 21:43 UTC by Chris Pelland
Modified: 2016-07-26 15:37 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1358036
Environment:
Last Closed: 2016-07-26 15:37:09 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1488 normal SHIPPED_LIVE CFME 5.5.5 bug fixes and enhancement update 2016-07-26 19:28:27 UTC

Description Chris Pelland 2016-07-19 21:43:21 UTC
+++ This bug was initially created as a clone of Bug #1358036 +++

Plato 1.6.0 recently came out, and brought in a dependency on strip-bom 3.0.0 (via eslint), which needs node 4+

This forces Plato to 1.4.0 which has no such dependencies.

Comment 2 CFME Bot 2016-07-19 22:36:39 UTC
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=4fd8e734a72ced3267b882c7b14fc3466bb0fe09

commit 4fd8e734a72ced3267b882c7b14fc3466bb0fe09
Merge: a3ae5b3 06fb747
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Tue Jul 19 18:31:45 2016 -0400
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Tue Jul 19 18:31:45 2016 -0400

    Merge branch 'fix-plato' into '5.5.z'
    
    Fix gulp ECMDERR on older node, by forcing plato to 1.4.*
    
    plato 1.6.0 recently came out, and brought in a dependency on strip-bom
    3.0.0 (via eslint), which needs node 4+
    
    This forces plato to 1.4.0 which has no such dependencies.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1358038
    
    See merge request !1017

 spa_ui/self_service/package.json | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comment 4 Dave Johnson 2016-07-26 00:21:40 UTC
[root@host-192-168-100-154 self_service]# grep plato package.json
    "plato": "~1.4.0",
[root@host-192-168-100-154 self_service]# rpm -qa | grep cfme
rh-ruby22-rubygem-redhat_access_cfme-0.0.7-1.el7cf.noarch
cfme-appliance-5.5.5.4-1.el7cf.x86_64
cfme-gemset-5.5.5.4-1.el7cf.x86_64
cfme-5.5.5.4-1.el7cf.x86_64

Comment 6 errata-xmlrpc 2016-07-26 15:37:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1488.html


Note You need to log in before you can comment on or make changes to this bug.