Bug 135805 - i18n missing in yum, causing rhn-applet-gui to quit
i18n missing in yum, causing rhn-applet-gui to quit
Status: CLOSED DUPLICATE of bug 135735
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-15 01:22 EDT by Tim Taiwanese Liim
Modified: 2014-01-21 17:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Taiwanese Liim 2004-10-15 01:22:35 EDT
Description of problem:
  When running rhn-applet-gui, I got this error msg:
        ImportError: No module named i18n
  and rhn-applet-gui quitted.

  It failed after I upgraded to yum-2.1.7-2.noarch.rpm.
  It worked with yum-2.1.4-1.noarch.rpm.

Version-Release number of selected component (if applicable):
    yum-2.1.7-2.noarch.rpm
    rhn-applet-2.1.11-1.i386.rpm

How reproducible:
    always.

Steps to Reproduce:
1. Install fc3test3.
2. update to development as of 10/14/04, with
    yum-2.1.7-2.noarch.rpm
    rhn-applet-2.1.11-1.i386.rpm
3. stop and start "rhn-applet-gui" from command line.
  
Actual results:
   At #3, I got this error:
        [timliim@formosa ~]$ rhn-applet-gui
        Traceback (most recent call last):
          File "/usr/bin/rhn-applet-gui", line 30, in ?
            import rhn_applet
          File "/usr/share/rhn/rhn_applet/rhn_applet.py", line 36, in ?
            from rhn_applet_model import rhnAppletModelGUI
          File "/usr/share/rhn/rhn_applet/rhn_applet_model.py", line
23, in ?
            from rhn_sources import getSources, changedSources
          File "/usr/share/rhn/rhn_applet/rhn_sources.py", line 8, in ?
            from sourcesConfig import SourcesConfigFile
          File "/usr/share/rhn/up2date_client/sourcesConfig.py", line
17, in ?
            import up2dateUtils
          File "/usr/share/rhn/up2date_client/up2dateUtils.py", line
17, in ?
            import rpmUtils
          File
"/usr/lib/python2.3/site-packages/rpmUtils/__init__.py", line 6, in ?
            import oldUtils
          File
"/usr/lib/python2.3/site-packages/rpmUtils/oldUtils.py", line 8, in ?
            from i18n import _
        ImportError: No module named i18n

Expected results:
    rhn-applet-gui should run without error.

Additional info:
    I set severity to high because rhn-applet-gui is unusable.
Comment 1 Seth Vidal 2004-10-15 01:24:02 EDT

*** This bug has been marked as a duplicate of 135735 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:06:19 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.