Bug 135811 - manpage doesn't document 'true' builtin
Summary: manpage doesn't document 'true' builtin
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: bash   
(Show other bugs)
Version: 1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-15 08:08 UTC by Mike A. Harris
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-10 12:22:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike A. Harris 2004-10-15 08:08:11 UTC
Description of problem:
The bash manpage does not document the "true" builtin, so people
will assume that "true" executes /bin/true.

Version-Release number of selected component (if applicable):
Stock FC1 + updates, FC2.

How reproducible:
100%

Steps to Reproduce:
1. man bash
2. search for the word 'true'
3. go through the entire manual, not finding 'true' documented
  
Actual results:
true is not found

Expected results:
true is found documented in the manpage

Additional info:
":" is preferred because it is documented.  ;o)

Comment 1 Mike A. Harris 2004-10-15 08:50:52 UTC
The GNU info pages don't document 'true' either.  ;)

Comment 2 Tim Waugh 2004-10-15 13:58:14 UTC
Reported upstream.


Note You need to log in before you can comment on or make changes to this bug.