Bug 1358125 - Virtio 1.0 driver didn't work on win10 with q35 machine type
Summary: Virtio 1.0 driver didn't work on win10 with q35 machine type
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.3
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Ladi Prosek
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-20 06:36 UTC by Yiqian Wei
Modified: 2016-11-04 08:55 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
NO_DOCS
Clone Of:
Environment:
Last Closed: 2016-11-04 08:55:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2609 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2016-11-03 15:27:12 UTC

Description Yiqian Wei 2016-07-20 06:36:01 UTC
Description of problem:
Q35 virtio_blk with virtio1.0 or virtio0.9 didn‘t work.

Version-Release number of selected component (if applicable):
kernel-3.10.0-470.el7.x86_64
qemu-kvm-rhev-2.6.0-13.el7.x86_64
seabios-1.9.1-4.el7.x86_64
virtio-win-prewhql-0.1.zip

How reproducible:
100%

Steps to Reproduce:
1.
/usr/libexec/qemu-kvm \
-M q35 \
-cpu SandyBridge \
-m 4G \
-name win10 \
-smp 4 \
-uuid 2fd41914-5019-4d17-a6cc-fa653ba516f5 \
-rtc base=localtime,driftfix=slew \
-qmp tcp:0:4444,server,nowait \
-monitor stdio \
-vga qxl \
-spice port=5931,disable-ticketing \
-device ioh3420,bus=pcie.0,id=root1.0,slot=1 \
-device x3130-upstream,bus=root1.0,id=upstream1.1 \
-device xio3130-downstream,bus=upstream1.1,id=downstream1.1,chassis=2 \
-drive if=none,id=drive0,file=/home/yiwei/win10.qcow2  \
-device virtio-blk-pci,drive=drive0,scsi=off,bus=downstream1.1,disable-legacy=on,disable-modern=off  \
-device ioh3420,bus=pcie.0,id=root1.2,slot=3 \
-device virtio-net-pci,bus=root1.2,netdev=tap3,mac=9a:6a:6b:6c:6d:63,disable-legacy=on,disable-modern=off \
-netdev tap,id=tap3,vhost=on \
-device ahci,id=ahci0 \
-drive file=/home/virtio-win-prewhql-86.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw \
-device ide-drive,bus=ahci0.0,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 \
-usbdevice mouse \
-usbdevice tablet \

2.#remote-viewer spice://10.66.10.43:5931

Actual results:
After update the driver, disk was found.

Expected results:
After driver update, disk can be found

Additional info:
1.pc machine type:no issue

Comment 2 Ladi Prosek 2016-07-26 07:09:51 UTC
This is caused by a missing initialization of a bus-related field in viostor, which is why it only reproduces on PCIe. Vioscsi uses a similar code pattern but does not have this issue.

Comment 4 lijin 2016-08-01 01:48:36 UTC
Could you try with latest build 124?
https://brewweb.engineering.redhat.com/brew/buildinfo?buildID=506954

Comment 5 Yiqian Wei 2016-08-01 02:33:21 UTC
(In reply to lijin from comment #4)
> Could you try with latest build 124?
> https://brewweb.engineering.redhat.com/brew/buildinfo?buildID==506954

Hi lijin,
  
   I've tested with latest build 124,After driver update, disk can be found.

   Version:
       kernel-3.10.0-478.el7.x86_64
       qemu-kvm-rhev-2.6.0-15.el7.x86_64
       seabios-1.9.1-4.el7.x86_64
       virtio-win-prewhql-0.1-124

Comment 6 lijin 2016-08-01 02:44:41 UTC
change status to verified according to comment#5

Comment 8 errata-xmlrpc 2016-11-04 08:55:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2609.html


Note You need to log in before you can comment on or make changes to this bug.