Bug 1358152 - [infrastructure_public_41]Create a petset can't create any pet [NEEDINFO]
Summary: [infrastructure_public_41]Create a petset can't create any pet
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: ---
Assignee: Clayton Coleman
QA Contact: DeShuai Ma
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-20 08:03 UTC by DeShuai Ma
Modified: 2016-09-27 09:41 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-27 09:41:09 UTC
Target Upstream Version:
agoldste: needinfo? (ccoleman)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1933 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.3 Release Advisory 2016-09-27 13:24:36 UTC

Description DeShuai Ma 2016-07-20 08:03:02 UTC
Description of problem:
When create a petset, the petset can't create any pod.

Version-Release number of selected component (if applicable):
openshift v3.3.0.7
kubernetes v1.3.0+57fb9ac
etcd 2.3.0+git

How reproducible:
Always

Steps to Reproduce:
1.Create a petset
oc create -f https://raw.githubusercontent.com/kubernetes/kubernetes.github.io/release-1.3/docs/user-guide/petset/bootstrapping/petset_vm.yaml -n dma

2.Check the petset and pod
$ oc get petset -n dma
$ oc describe petset vm -n dma
$ oc get pod -n dma
$ oc get pvc -n dma

Actual results:
2.There is any pod
[root@ip-172-18-2-210 ~]# oc get petset -n dma
NAME      DESIRED   CURRENT   AGE
vm        2         0         17m
[root@ip-172-18-2-210 ~]# oc describe petset vm -n dma
Name:			vm
Namespace:		dma
Image(s):		ubuntu:15.10
Selector:		app=ub
Labels:			app=ub
Replicas:		0 current / 2 desired
Annotations:		<none>
CreationTimestamp:	Wed, 20 Jul 2016 01:36:25 -0400
Pods Status:		0 Running / 0 Waiting / 0 Succeeded / 0 Failed
No volumes.
No events.

[root@ip-172-18-2-210 ~]# oc get pod -n dma
[root@ip-172-18-2-210 ~]# oc get pvc -n dma
[root@ip-172-18-2-210 ~]# 

Expected results:
2. There should be two pods and running

Additional info:

Comment 1 DeShuai Ma 2016-08-04 07:52:46 UTC
Test on openshift v3.3.0.14, still same issue, high this bug.

Comment 2 Andy Goldstein 2016-08-05 20:26:49 UTC
We just merged support for PetSets to origin - https://github.com/openshift/origin/pull/9972

Comment 3 Troy Dawson 2016-08-08 21:37:31 UTC
This has been merged and is in OSE v3.3.0.17 or newer.

Comment 5 DeShuai Ma 2016-08-09 07:50:11 UTC
Test on v3.3.0.17 on aws, two issue for petset now:

1) There is pvc, but event show pvc not found. like:"FailedCreate pvc: usr-vm-0, error: persistentvolumeclaims "usr-vm-0" not found"
[root@dhcp-128-7 dma]# oc describe petset vm
Name:			vm
Namespace:		dma1
Image(s):		ubuntu:15.10
Selector:		app=ub
Labels:			app=ub
Replicas:		2 current / 2 desired
Annotations:		<none>
CreationTimestamp:	Tue, 09 Aug 2016 15:17:52 +0800
Pods Status:		0 Running / 1 Waiting / 0 Succeeded / 0 Failed
No volumes.
Events:
  FirstSeen	LastSeen	Count	From		SubobjectPath	Type		Reason			Message
  ---------	--------	-----	----		-------------	--------	------			-------
  48s		48s		1	{petset }			Warning		FailedCreate		pvc: usr-vm-0, error: persistentvolumeclaims "usr-vm-0" not found
  48s		48s		1	{petset }			Warning		FailedCreate		pvc: lib-vm-0, error: persistentvolumeclaims "lib-vm-0" not found
  48s		48s		1	{petset }			Warning		FailedCreate		pvc: etc-vm-0, error: persistentvolumeclaims "etc-vm-0" not found
  48s		48s		1	{petset }			Normal		SuccessfulCreate	pet: vm-0
  48s		48s		1	{petset }			Warning		FailedCreate		pvc: usr-vm-1, error: persistentvolumeclaims "usr-vm-1" not found
  47s		47s		1	{petset }			Warning		FailedCreate		pvc: lib-vm-1, error: persistentvolumeclaims "lib-vm-1" not found
  47s		47s		1	{petset }			Warning		FailedCreate		pvc: etc-vm-1, error: persistentvolumeclaims "etc-vm-1" not found


[root@dhcp-128-7 dma]# oc get pvc
NAME       STATUS    VOLUME                                     CAPACITY   ACCESSMODES   AGE
etc-vm-0   Bound     pvc-62d5dd73-5e01-11e6-9640-0e64fc40c135   0                        1m
etc-vm-1   Bound     pvc-62feecd8-5e01-11e6-9640-0e64fc40c135   0                        1m
lib-vm-0   Bound     pvc-62d23bf0-5e01-11e6-9640-0e64fc40c135   0                        1m
lib-vm-1   Bound     pvc-62fc6678-5e01-11e6-9640-0e64fc40c135   0                        1m
usr-vm-0   Bound     pvc-62ce0215-5e01-11e6-9640-0e64fc40c135   0                        1m
usr-vm-1   Bound     pvc-62f755b9-5e01-11e6-9640-0e64fc40c135   0                        1m
2) There is bug about dynamically provisioning persistent volumes, so the petset with pv always failed.
https://bugzilla.redhat.com/show_bug.cgi?id=1365398

Comment 6 DeShuai Ma 2016-08-17 09:36:16 UTC
BZ1365398 is closed. I test petset with pv, it can works well. But now still has some persistentvolumeclaims not found event as comment5.
If you think those event is normal, this bug can be verified.
thanks.

Comment 7 Andy Goldstein 2016-08-17 10:05:46 UTC
Clayton or Jan, can you answer comment 6?

Comment 8 Jan Chaloupka 2016-08-17 11:03:41 UTC
DeShuai, can you:

1) reproduce the same with kubernetes kubernetes v1.3.0+57fb9ac only?
2) do the same with pre-created claims?

Comment 9 DeShuai Ma 2016-08-18 08:21:37 UTC
(In reply to Jan Chaloupka from comment #8)
> DeShuai, can you:
> 
> 1) reproduce the same with kubernetes kubernetes v1.3.0+57fb9ac only?
> 2) do the same with pre-created claims?

1) This is the result of openshift 3.3 not kubernetes
2) not pre-created claims.
All the resource create by:
oc create -f https://raw.githubusercontent.com/kubernetes/kubernetes.github.io/release-1.3/docs/user-guide/petset/bootstrapping/petset_vm.yaml

Comment 10 DeShuai Ma 2016-09-01 05:53:31 UTC
As petset now works fine, for the event issue will do a deep research, if still a issue will file a separate bug.
Verify this bug.

Comment 12 errata-xmlrpc 2016-09-27 09:41:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1933


Note You need to log in before you can comment on or make changes to this bug.