Bug 1358229 - Traceback message should be fixed, seen while editing winsync migrated user information in Default trust view.
Summary: Traceback message should be fixed, seen while editing winsync migrated user i...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Keywords:
Depends On: 1360245
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-20 10:17 UTC by Sudhir Menon
Modified: 2016-11-04 05:58 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-04 05:58:43 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Sudhir Menon 2016-07-20 10:17:02 UTC
Description of problem: Traceback message is displayed in httpd/error_log file
when we try to modify entries related to user present in 'Default Trust View' post winsync-migrate.

Version-Release number of selected component (if applicable):
ipa-server-4.4.0-2.1.el7.x86_64

How reproducible:Always


Steps to Reproduce:
1. Establish winsync agreement with AD
2. Establish trust with same AD
3. Ran ipa-winsync-migrate
4. Ensure that the users are placed in 'Default Trust View'
5. Select any one of the user
6. Edit the description for the user.

Actual results:
1. Below message is displayed on the UI

IPA Error 4001: NotFound
no such entry

2. httpd/error_log displays the below message.
[Wed Jul 20 15:37:08.998909 2016] [:error] [pid 7431] ipa: INFO: [jsonserver_session] admin@TESTRELM.TEST: batch(({u'params': ((u'CHD.PNE.QE_id_range',), {}), u'method': u'idrange_show'}, {u'params': ((u'PNE.QE_id_range',), {}), u'method': u'idrange_show'}, {u'params': ((u'TESTRELM.TEST_id_range',), {}), u'method': u'idrange_show'}), version=u'2.210'): SUCCESS
[Wed Jul 20 15:37:10.624367 2016] [:error] [pid 7431] ipa: INFO: [jsonserver_session] admin@TESTRELM.TEST: idoverrideuser_find(u'Default Trust View', u'', sizelimit=0, version=u'2.210'): SUCCESS
[Wed Jul 20 15:37:17.159007 2016] [:error] [pid 7431] ipa: INFO: admin@TESTRELM.TEST: batch: idoverrideuser_show(u'Default Trust View', u'user2@pne.qe', rights=True, all=True): SUCCESS
[Wed Jul 20 15:37:17.159282 2016] [:error] [pid 7431] ipa: INFO: admin@TESTRELM.TEST: batch: cert_find(None): OptionError
[Wed Jul 20 15:37:17.159506 2016] [:error] [pid 7431] ipa: INFO: [jsonserver_session] admin@TESTRELM.TEST: batch(({u'params': ((u'Default Trust View', u'user2@pne.qe'), {u'all': True, u'rights': True}), u'method': u'idoverrideuser_show'}, {u'params': ((), {u'idoverrideuser': (u'user2@pne.qe',), u'all': True}), u'method': u'cert_find'}), version=u'2.210'): SUCCESS
[Wed Jul 20 15:37:18.726842 2016] [:error] [pid 7431] ipa: INFO: [jsonserver_session] admin@TESTRELM.TEST: user_show(u'user2@pne.qe', version=u'2.210'): NotFound
[Wed Jul 20 15:37:20.253935 2016] [:error] [pid 7430] ipa: INFO: [jsonserver_session] admin@TESTRELM.TEST: cert_find(None, version=u'2.210'): SUCCESS
[Wed Jul 20 15:37:29.692620 2016] [:error] [pid 7431] ipa: ERROR: non-public: ValueError: non-generic 'MidairCollision' needs format=None; got format=Gettext('the entry was deleted while being modified', domain='ipa', localedir=None)
[Wed Jul 20 15:37:29.692658 2016] [:error] [pid 7431] Traceback (most recent call last):
[Wed Jul 20 15:37:29.692662 2016] [:error] [pid 7431]   File "/usr/lib/python2.7/site-packages/ipaserver/rpcserver.py", line 352, in wsgi_execute
[Wed Jul 20 15:37:29.692664 2016] [:error] [pid 7431]     result = self.Command[name](*args, **options)
[Wed Jul 20 15:37:29.692666 2016] [:error] [pid 7431]   File "/usr/lib/python2.7/site-packages/ipalib/frontend.py", line 447, in __call__
[Wed Jul 20 15:37:29.692668 2016] [:error] [pid 7431]     return self.__do_call(*args, **options)
[Wed Jul 20 15:37:29.692670 2016] [:error] [pid 7431]   File "/usr/lib/python2.7/site-packages/ipalib/frontend.py", line 475, in __do_call
[Wed Jul 20 15:37:29.692672 2016] [:error] [pid 7431]     ret = self.run(*args, **options)
[Wed Jul 20 15:37:29.692674 2016] [:error] [pid 7431]   File "/usr/lib/python2.7/site-packages/ipalib/frontend.py", line 797, in run
[Wed Jul 20 15:37:29.692676 2016] [:error] [pid 7431]     return self.execute(*args, **options)
[Wed Jul 20 15:37:29.692678 2016] [:error] [pid 7431]   File "/usr/lib/python2.7/site-packages/ipaserver/plugins/baseldap.py", line 1469, in execute
[Wed Jul 20 15:37:29.692681 2016] [:error] [pid 7431]     format=_('the entry was deleted while being modified')
[Wed Jul 20 15:37:29.692683 2016] [:error] [pid 7431]   File "/usr/lib/python2.7/site-packages/ipalib/errors.py", line 264, in __init__
[Wed Jul 20 15:37:29.692685 2016] [:error] [pid 7431]     messages.process_message_arguments(self, format, message, **kw)
[Wed Jul 20 15:37:29.692696 2016] [:error] [pid 7431]   File "/usr/lib/python2.7/site-packages/ipalib/messages.py", line 63, in process_message_arguments
[Wed Jul 20 15:37:29.692699 2016] [:error] [pid 7431]     name, format)
[Wed Jul 20 15:37:29.692702 2016] [:error] [pid 7431] ValueError: non-generic 'MidairCollision' needs format=None; got format=Gettext('the entry was deleted while being modified', domain='ipa', localedir=None)
[Wed Jul 20 15:37:29.693020 2016] [:error] [pid 7431] ipa: INFO: [jsonserver_session] admin@TESTRELM.TEST: idoverrideuser_mod(u'Default Trust View', u'user2@pne.qe', description=u'TEST', rights=True, all=True, version=u'2.210'): ValueError
[Wed Jul 20 15:38:04.255173 2016] [:error] [pid 7430] ipa: INFO: [jsonserver_session] admin@TESTRELM.TEST: idoverrideuser_mod(u'Default Trust View', u'user2@pne.qe', description=u'TESTTESTTEST', rights=True, all=True, version=u'2.210'): NotFound
[Wed Jul 20 15:42:06.796062 2016] [:error] [pid 7430] ipa: INFO: [jsonserver_session] admin@TESTRELM.TEST: idoverrideuser_mod(u'Default Trust View', u'user2@pne.qe', description=u'TESTTESTTEST', rights=True, all=True, version=u'2.210'): NotFound
[Wed Jul 20 15:42:19.859738 2016] [:error] [pid 7431] ipa: INFO: [jsonserver_session] admin@TESTRELM.TEST: user_show(u'user2@pne.qe', version=u'2.210'): NotFound
[Wed Jul 20 15:42:29.335159 2016] [:error] [pid 7430] ipa: INFO: [jsonserver_session] admin@TESTRELM.TEST: idoverrideuser_mod(u'Default Trust View', u'user2@pne.qe', description=u'TEST', rights=True, all=True, version=u'2.210'): NotFound
[Wed Jul 20 15:42:32.540790 2016] [:error] [pid 7431] ipa: INFO: [jsonserver_session] admin@TESTRELM.TEST: idoverrideuser_mod(u'Default Trust View', u'user2@pne.qe', description=u'TEST', rights=True, all=True, version=u'2.210'): NotFound

Expected results: Traceback message should be fixed.


Additional info:

Comment 1 Petr Vobornik 2016-07-20 10:33:34 UTC
looks like duplicate of bug 1356139

Comment 3 Martin Bašti 2016-07-27 12:09:37 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/6097

Comment 4 Martin Babinsky 2016-07-27 12:13:36 UTC
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/dc62dd8c908b3c8a8c166006d2d4e71dde99883e

Comment 7 Sudhir Menon 2016-08-24 08:01:26 UTC
Observations: 

1.'MidairCollision' is not displayed in the logs when user information are modified in the 'Default Trust view'

2.Could see the below in error_log when description for the user was changed.
string_to_sid: SID test3@pne.qe is not in a valid format. Is this expected?

[root@ipaserver ~]# ipa idoverrideuser-find 'Default Trust View'
Anchor to override: test3@pne.qe
Description: changing description
User login: test3
UID: 1335600001
GECOS: test3
GID: 1335600001
Login shell: /bin/sh

===error_log===
[Wed Aug 24 13:24:48.181615 2016] [:error] [pid 24022] ipa: INFO: [jsonserver_session] admin@REDLABS.QE: idoverrideuser_find(u'Default Trust View', u'', sizelimit=0, version=u'2.212'): SUCCESS
string_to_sid: SID test3@pne.qe is not in a valid format
[Wed Aug 24 13:24:50.098634 2016] [:error] [pid 24021] ipa: INFO: admin@REDLABS.QE: batch: idoverrideuser_show(u'Default Trust View', u'test3@pne.qe', rights=True, all=True): SUCCESS
[Wed Aug 24 13:24:50.098897 2016] [:error] [pid 24021] ipa: INFO: admin@REDLABS.QE: batch: cert_find(None): OptionError
[Wed Aug 24 13:24:50.099145 2016] [:error] [pid 24021] ipa: INFO: [jsonserver_session] admin@REDLABS.QE: batch(({u'params': ((u'Default Trust View', u'test3@pne.qe'), {u'all': True, u'rights': True}), u'method': u'idoverrideuser_show'}, {u'params': ((), {u'idoverrideuser': (u'test3@pne.qe',), u'all': True}), u'method': u'cert_find'}), version=u'2.212'): SUCCESS
[Wed Aug 24 13:24:50.181391 2016] [:error] [pid 24022] ipa: INFO: [jsonserver_session] admin@REDLABS.QE: user_show(u'test3@pne.qe', version=u'2.212'): NotFound
string_to_sid: SID test3@pne.qe is not in a valid format    <====
string_to_sid: SID test3@pne.qe is not in a valid format    <====
[Wed Aug 24 13:24:57.580994 2016] [:error] [pid 24021] ipa: INFO: [jsonserver_session] admin@REDLABS.QE: idoverrideuser_mod(u'Default Trust View', u'test3@pne.qe', description=u'changing description', rights=True, all=True, version=u'2.212'): SUCCESS
[Wed Aug 24 13:24:57.641102 2016] [:error] [pid 24022] ipa: INFO: [jsonserver_session] admin@REDLABS.QE: user_show(u'test3@pne.qe', version=u'2.212'): NotFound

Comment 8 Martin Babinsky 2016-09-02 08:25:37 UTC
Sudhir,

I was unable to reproduce this behavior in my environment. Can you please provide exact steps you have taken before observing the error message? Does it affect the functionality of the test somehow?

Comment 9 Sudhir Menon 2016-09-02 09:02:10 UTC
Martin,
I could see the error while verifying this bugzilla.

1. Establish winsync agreement with AD
2. Establish trust with same AD
3. Ran ipa-winsync-migrate

Although it doesn't affect the functionality of the test, but was concerned with the message seen in error_log

string_to_sid: SID test3@pne.qe is not in a valid format    <====
string_to_sid: SID test3@pne.qe is not in a valid format    <====

Will have to try to reproduce this issue, if its not seen at your end.

Comment 10 Petr Vobornik 2016-09-05 16:14:19 UTC
Sudhir could you paste here output of
  ipa idoverrideuser-show 'Default Trust View' test3@pne.qe --all --raw

And relevant http error log after calling it.

Comment 11 Martin Babinsky 2016-09-07 14:54:02 UTC
Hi Sudhir,

I tried winsync-migrate on my setup at least three times and did not see the message in the error log.

If it does not interfere with bug verification I would consider it harmless and proceed. You can open a sperate BZ about this issue if you wish.

Comment 13 Sudhir Menon 2016-09-14 17:49:25 UTC
Petr/Martin/Alexander

I am not able to reproduce the issue mentioned in comment #9 on a pristine system.
Hence marking the bug as verified.


Verified on RHEL73 using

ipa-server-trust-ad-4.4.0-11.el7.x86_64
ipa-server-4.4.0-11.el7.x86_64


[root@master slapd-TESTRELM-TEST]# ipa-replica-manage connect --winsync --passsync=password --cacert=/etc/dirsrv/slapd-TESTRELM-TEST/ADcert.cer apache.pne.qe --binddn "cn=Administrator,cn=Users,dc=pne,dc=qe" --bindpw Secret123 -v -p Secret123
Added CA certificate /etc/dirsrv/slapd-TESTRELM-TEST/ADcert.cer to certificate database for master.testrelm.test
ipa: INFO: AD Suffix is: DC=pne,DC=qe
The user for the Windows PassSync service is uid=passsync,cn=sysaccounts,cn=etc,dc=testrelm,dc=test
Adding Windows PassSync system account
ipa: INFO: Added new sync agreement, waiting for it to become ready . . .
ipa: INFO: Replication Update in progress: FALSE: status: Error (0) Replica acquired successfully: Incremental update started: start: 0: end: 0
ipa: INFO: Agreement is ready, starting replication . . .
Starting replication, please wait until this has completed.
Update in progress, 5 seconds elapsed
Update succeeded
 
Connected 'master.testrelm.test' to 'apache.pne.qe'
 
[root@master slapd-TESTRELM-TEST]# ipa-replica-manage list
apache.pne.qe: winsync
master.testrelm.test: master


[root@master slapd-TESTRELM-TEST]# ipa trust-add --two-way=true
Realm name: pne.qe
Active Directory domain administrator: Administrator
Active Directory domain administrator's password:
-----------------------------------------------
Added Active Directory trust for realm "pne.qe"
-----------------------------------------------
  Realm name: pne.qe
  Domain NetBIOS name: PNE
  Domain Security Identifier: S-1-5-21-3912719521-1967590360-1136226524
  Trust direction: Two-way trust
  Trust type: Active Directory domain
  Trust status: Established and verified
 

[root@master slapd-TESTRELM-TEST]# ipa-winsync-migrate --realm=PNE.QE  --server=apache.pne.qe -v
ipa.ipaserver.plugins.trust.trust_show: DEBUG: raw: trust_show(u'PNE.QE', version=u'2.213')
ipa.ipaserver.plugins.trust.trust_show: DEBUG: trust_show(u'PNE.QE', rights=False, all=False, raw=False, version=u'2.213')
ipa.ipapython.ipaldap.SchemaCache: DEBUG: retrieving schema for SchemaCache url=ldapi://%2fvar%2frun%2fslapd-TESTRELM-TEST.socket conn=<ldap.ldapobject.SimpleLDAPObject instance at 0x4f89d40>
ipa.ipapython.ipaldap.SchemaCache: DEBUG: flushing ldaps://master.testrelm.test:636 from SchemaCache
ipa.ipapython.ipaldap.SchemaCache: DEBUG: retrieving schema for SchemaCache url=ldaps://master.testrelm.test:636 conn=<ldap.ldapobject.SimpleLDAPObject instance at 0x525a8c0>
ipa.ipaserver.install.ipa_winsync_migrate.WinsyncMigrate: DEBUG: Not logging to a file
ipa.ipaserver.install.ipa_winsync_migrate.WinsyncMigrate: DEBUG: ipa-winsync-migrate was invoked with arguments [] and options: {'realm': 'PNE.QE', 'verbose': True, 'quiet': False, 'server': 'apache.pne.qe', 'log_file': None, 'interactive': True}
ipa.ipaserver.install.ipa_winsync_migrate.WinsyncMigrate: DEBUG: IPA version 4.4.0-11.el7
ipa: DEBUG: Failed to remove referral value: {'desc': 'No such attribute'}
ipa.ipaserver.install.ipa_winsync_migrate.WinsyncMigrate: DEBUG: Discovered entry: LDAPEntry(ipapython.dn.DN('uid=sudhir,cn=users,cn=accounts,dc=testrelm,dc=test'), {u'cn': ['sudhir'], u'objectClass': ['top', 'person', 'organizationalperson', 'inetOrgPerson', 'ntUser', 'inetuser', 'posixaccount', 'krbprincipalaux', 'krbticketpolicyaux', 'ipaobject', 'ipasshuser', 'ipaSshGroupOfPubKeys', 'mepOriginEntry'], u'loginShell': ['/bin/sh'], u'ntUniqueId': ['4d042f91beefb940978c636ef51ff6ca'], u'ntUserLastLogon': ['131153766445383117'], u'mepManagedEntry': ['cn=sudhir,cn=groups,cn=accounts,dc=testrelm,dc=test'], u'gidNumber': ['1143000001'], u'ntUserAcctExpires': ['9223372036854775807'], u'krbPrincipalName': ['sudhir@TESTRELM.TEST'], u'ntUserDeleteAccount': ['true'], u'ntUserDomainId': ['sudhir'], u'uid': ['sudhir'], u'ntUserCodePage': ['0'], u'gecos': ['sudhir'], u'ipaUniqueID': ['4753c73a-7aa1-11e6-afe3-525400e715b1'], u'homeDirectory': ['/home/sudhir'], u'uidNumber': ['1143000001'], u'givenName': ['sudhir'], u'sn': ['s']})
ipa.ipaserver.install.ipa_winsync_migrate.WinsyncMigrate: DEBUG: Discovered entry: LDAPEntry(ipapython.dn.DN('uid=user1,cn=users,cn=accounts,dc=testrelm,dc=test'), {u'cn': ['user1'], u'objectClass': ['top', 'person', 'organizationalperson', 'inetOrgPerson', 'ntUser', 'inetuser', 'posixaccount', 'krbprincipalaux', 'krbticketpolicyaux', 'ipaobject', 'ipasshuser', 'ipaSshGroupOfPubKeys', 'mepOriginEntry'], u'loginShell': ['/bin/sh'], u'ntUniqueId': ['1a9b32a5c500aa4789796b6ce35529db'], u'ntUserLastLogon': ['131177853272385714'], u'mepManagedEntry': ['cn=user1,cn=groups,cn=accounts,dc=testrelm,dc=test'], u'gidNumber': ['1143000003'], u'ntUserAcctExpires': ['9223372036854775807'], u'krbPrincipalName': ['user1@TESTRELM.TEST'], u'ntUserDeleteAccount': ['true'], u'ntUserDomainId': ['user1'], u'uid': ['user1'], u'ntUserCodePage': ['0'], u'gecos': ['user1'], u'ipaUniqueID': ['47dfc78a-7aa1-11e6-afe3-525400e715b1'], u'homeDirectory': ['/home/user1'], u'uidNumber': ['1143000003'], u'givenName': ['user1'], u'sn': ['s']})
ipa.ipaserver.install.ipa_winsync_migrate.WinsyncMigrate: DEBUG: Discovered entry: LDAPEntry(ipapython.dn.DN('uid=sachin,cn=users,cn=accounts,dc=testrelm,dc=test'), {u'cn': ['sachin'], u'objectClass': ['top', 'person', 'organizationalperson', 'inetOrgPerson', 'ntUser', 'inetuser', 'posixaccount', 'krbprincipalaux', 'krbticketpolicyaux', 'ipaobject', 'ipasshuser', 'ipaSshGroupOfPubKeys', 'mepOriginEntry'], u'loginShell': ['/bin/sh'], u'ntUniqueId': ['f2fae287dd330d4cbfb0310f228a9d54'], u'ntUserLastLogon': ['131178089597636464'], u'mepManagedEntry': ['cn=sachin,cn=groups,cn=accounts,dc=testrelm,dc=test'], u'gidNumber': ['1143000004'], u'ntUserAcctExpires': ['9223372036854775807'], u'krbPrincipalName': ['sachin@TESTRELM.TEST'], u'ntUserDeleteAccount': ['true'], u'ntUserDomainId': ['sachin'], u'uid': ['sachin'], u'ntUserCodePage': ['0'], u'gecos': ['sachin'], u'ipaUniqueID': ['483513de-7aa1-11e6-afe3-525400e715b1'], u'homeDirectory': ['/home/sachin'], u'uidNumber': ['1143000004'], u'givenName': ['sachin'], u'sn': ['s']})
ipa.ipaserver.install.ipa_winsync_migrate.WinsyncMigrate: DEBUG: Discovered entry: LDAPEntry(ipapython.dn.DN('uid=win1,cn=users,cn=accounts,dc=testrelm,dc=test'), {u'cn': ['win1'], u'objectClass': ['top', 'person', 'organizationalperson', 'inetOrgPerson', 'ntUser', 'inetuser', 'posixaccount', 'krbprincipalaux', 'krbticketpolicyaux', 'ipaobject', 'ipasshuser', 'ipaSshGroupOfPubKeys', 'mepOriginEntry'], u'loginShell': ['/bin/sh'], u'ntUniqueId': ['5ec71eba01f7664bb812487ef6abd50e'], u'ntUserLastLogon': ['131178162739669423'], u'mepManagedEntry': ['cn=win1,cn=groups,cn=accounts,dc=testrelm,dc=test'], u'gidNumber': ['1143000005'], u'ntUserAcctExpires': ['9223372036854775807'], u'krbPrincipalName': ['win1@TESTRELM.TEST'], u'ntUserDeleteAccount': ['true'], u'ntUserDomainId': ['win1'], u'uid': ['win1'], u'ntUserCodePage': ['0'], u'gecos': ['win1'], u'ipaUniqueID': ['4859d610-7aa1-11e6-afe3-525400e715b1'], u'homeDirectory': ['/home/win1'], u'uidNumber': ['1143000005'], u'givenName': ['win1'], u'sn': ['s']})
ipa.ipaserver.install.ipa_winsync_migrate.WinsyncMigrate: DEBUG: Discovered entry: LDAPEntry(ipapython.dn.DN('uid=First.Last,cn=users,cn=accounts,dc=testrelm,dc=test'), {u'cn': ['First Last'], u'objectClass': ['top', 'person', 'organizationalperson', 'inetOrgPerson', 'ntUser', 'inetuser', 'posixaccount', 'krbprincipalaux', 'krbticketpolicyaux', 'ipaobject', 'ipasshuser', 'ipaSshGroupOfPubKeys', 'mepOriginEntry'], u'loginShell': ['/bin/sh'], u'ntUniqueId': ['2a6810bdf1ba994185c2fff0d6b3b68b'], u'ntUserLastLogon': ['131178000266861295'], u'mepManagedEntry': ['cn=First.Last,cn=groups,cn=accounts,dc=testrelm,dc=test'], u'gidNumber': ['1143000006'], u'ntUserAcctExpires': ['9223372036854775807'], u'krbPrincipalName': ['first.last@TESTRELM.TEST'], u'ntUserDeleteAccount': ['true'], u'ntUserDomainId': ['First.Last'], u'uid': ['first.last'], u'ntUserCodePage': ['0'], u'gecos': ['First Last'], u'ipaUniqueID': ['487c8ade-7aa1-11e6-afe3-525400e715b1'], u'homeDirectory': ['/home/first.last'], u'uidNumber': ['1143000006'], u'givenName': ['First'], u'sn': ['Last']})
ipa.ipaserver.install.ipa_winsync_migrate.WinsyncMigrate: DEBUG: Discovered entry: LDAPEntry(ipapython.dn.DN('uid=test1,cn=users,cn=accounts,dc=testrelm,dc=test'), {u'cn': ['test1'], u'objectClass': ['top', 'person', 'organizationalperson', 'inetOrgPerson', 'ntUser', 'inetuser', 'posixaccount', 'krbprincipalaux', 'krbticketpolicyaux', 'ipaobject', 'ipasshuser', 'ipaSshGroupOfPubKeys', 'mepOriginEntry'], u'loginShell': ['/bin/sh'], u'ntUniqueId': ['cd0f1e9658a35648b28d7112f5e869e4'], u'mepManagedEntry': ['cn=test1,cn=groups,cn=accounts,dc=testrelm,dc=test'], u'gidNumber': ['1143000007'], u'ntUserAcctExpires': ['9223372036854775807'], u'krbPrincipalName': ['test1@TESTRELM.TEST'], u'ntUserDeleteAccount': ['true'], u'ntUserDomainId': ['test1'], u'uid': ['test1'], u'ntUserCodePage': ['0'], u'gecos': ['test1'], u'ipaUniqueID': ['48ef573a-7aa1-11e6-afe3-525400e715b1'], u'homeDirectory': ['/home/test1'], u'uidNumber': ['1143000007'], u'givenName': ['test1'], u'sn': ['s']})
ipa.ipaserver.plugins.idviews.idoverrideuser_add: DEBUG: raw: idoverrideuser_add(u'Default Trust View', u'sudhir@PNE.QE', uid=u'sudhir', uidnumber=u'1143000001', gecos=u'sudhir', gidnumber=u'1143000001', loginshell=u'/bin/sh', version=u'2.213')
ipa.ipaserver.plugins.idviews.idoverrideuser_add: DEBUG: idoverrideuser_add(u'Default Trust View', u'sudhir@PNE.QE', uid=u'sudhir', uidnumber=1143000001, gecos=u'sudhir', gidnumber=1143000001, loginshell=u'/bin/sh', fallback_to_ldap=False, all=False, raw=False, version=u'2.213')
ipa: DEBUG: Converting SID to object name: S-1-5-21-3912719521-1967590360-1136226524-1482
ipa: DEBUG: Converting SID to object name: S-1-5-21-3912719521-1967590360-1136226524-1482
ipa.ipaserver.install.ipa_winsync_migrate.WinsyncMigrate: DEBUG: Migrated: sudhir@PNE.QE
ipa.ipaserver.plugins.idviews.idoverrideuser_add: DEBUG: raw: idoverrideuser_add(u'Default Trust View', u'user1@PNE.QE', uid=u'user1', uidnumber=u'1143000003', gecos=u'user1', gidnumber=u'1143000003', loginshell=u'/bin/sh', version=u'2.213')
ipa.ipaserver.plugins.idviews.idoverrideuser_add: DEBUG: idoverrideuser_add(u'Default Trust View', u'user1@PNE.QE', uid=u'user1', uidnumber=1143000003, gecos=u'user1', gidnumber=1143000003, loginshell=u'/bin/sh', fallback_to_ldap=False, all=False, raw=False, version=u'2.213')
ipa: DEBUG: Converting SID to object name: S-1-5-21-3912719521-1967590360-1136226524-1494
ipa: DEBUG: Converting SID to object name: S-1-5-21-3912719521-1967590360-1136226524-1494
ipa.ipaserver.install.ipa_winsync_migrate.WinsyncMigrate: DEBUG: Migrated: user1@PNE.QE
ipa.ipaserver.plugins.idviews.idoverrideuser_add: DEBUG: raw: idoverrideuser_add(u'Default Trust View', u'sachin@PNE.QE', uid=u'sachin', uidnumber=u'1143000004', gecos=u'sachin', gidnumber=u'1143000004', loginshell=u'/bin/sh', version=u'2.213')
ipa.ipaserver.plugins.idviews.idoverrideuser_add: DEBUG: idoverrideuser_add(u'Default Trust View', u'sachin@PNE.QE', uid=u'sachin', uidnumber=1143000004, gecos=u'sachin', gidnumber=1143000004, loginshell=u'/bin/sh', fallback_to_ldap=False, all=False, raw=False, version=u'2.213')
ipa: DEBUG: Converting SID to object name: S-1-5-21-3912719521-1967590360-1136226524-1537
ipa: DEBUG: Converting SID to object name: S-1-5-21-3912719521-1967590360-1136226524-1537
ipa.ipaserver.install.ipa_winsync_migrate.WinsyncMigrate: DEBUG: Migrated: sachin@PNE.QE
ipa.ipaserver.plugins.idviews.idoverrideuser_add: DEBUG: raw: idoverrideuser_add(u'Default Trust View', u'win1@PNE.QE', uid=u'win1', uidnumber=u'1143000005', gecos=u'win1', gidnumber=u'1143000005', loginshell=u'/bin/sh', version=u'2.213')
ipa.ipaserver.plugins.idviews.idoverrideuser_add: DEBUG: idoverrideuser_add(u'Default Trust View', u'win1@PNE.QE', uid=u'win1', uidnumber=1143000005, gecos=u'win1', gidnumber=1143000005, loginshell=u'/bin/sh', fallback_to_ldap=False, all=False, raw=False, version=u'2.213')
ipa: DEBUG: Converting SID to object name: S-1-5-21-3912719521-1967590360-1136226524-1538
ipa: DEBUG: Converting SID to object name: S-1-5-21-3912719521-1967590360-1136226524-1538
ipa.ipaserver.install.ipa_winsync_migrate.WinsyncMigrate: DEBUG: Migrated: win1@PNE.QE
ipa.ipaserver.plugins.idviews.idoverrideuser_add: DEBUG: raw: idoverrideuser_add(u'Default Trust View', u'first.last@PNE.QE', uid=u'first.last', uidnumber=u'1143000006', gecos=u'First Last', gidnumber=u'1143000006', loginshell=u'/bin/sh', version=u'2.213')
ipa.ipaserver.plugins.idviews.idoverrideuser_add: DEBUG: idoverrideuser_add(u'Default Trust View', u'first.last@PNE.QE', uid=u'first.last', uidnumber=1143000006, gecos=u'First Last', gidnumber=1143000006, loginshell=u'/bin/sh', fallback_to_ldap=False, all=False, raw=False, version=u'2.213')
ipa: DEBUG: Converting SID to object name: S-1-5-21-3912719521-1967590360-1136226524-1535
ipa: DEBUG: Converting SID to object name: S-1-5-21-3912719521-1967590360-1136226524-1535
ipa.ipaserver.install.ipa_winsync_migrate.WinsyncMigrate: DEBUG: Migrated: first.last@PNE.QE
ipa.ipaserver.plugins.idviews.idoverrideuser_add: DEBUG: raw: idoverrideuser_add(u'Default Trust View', u'test1@PNE.QE', uid=u'test1', uidnumber=u'1143000007', gecos=u'test1', gidnumber=u'1143000007', loginshell=u'/bin/sh', version=u'2.213')
ipa.ipaserver.plugins.idviews.idoverrideuser_add: DEBUG: idoverrideuser_add(u'Default Trust View', u'test1@PNE.QE', uid=u'test1', uidnumber=1143000007, gecos=u'test1', gidnumber=1143000007, loginshell=u'/bin/sh', fallback_to_ldap=False, all=False, raw=False, version=u'2.213')
ipa: DEBUG: Converting SID to object name: S-1-5-21-3912719521-1967590360-1136226524-1596
ipa: DEBUG: Converting SID to object name: S-1-5-21-3912719521-1967590360-1136226524-1596
ipa.ipaserver.install.ipa_winsync_migrate.WinsyncMigrate: DEBUG: Migrated: test1@PNE.QE
ipa.ipaserver.install.ipa_winsync_migrate.WinsyncMigrate: WARNING: Migration completed. Please note that if PassSync was configured on the given Active Directory server, it needs to be manually removed, otherwise it may try to reset password for accounts that are no longer existent.
ipa.ipaserver.install.ipa_winsync_migrate.WinsyncMigrate: INFO: The ipa-winsync-migrate command was successful

Comment 15 errata-xmlrpc 2016-11-04 05:58:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.