This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 135828 - "Network Configuration" help should warn about PCMCIA and "Active on Boot"
"Network Configuration" help should warn about PCMCIA and "Active on Boot"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda-help (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
:
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2004-10-15 05:57 EDT by Barry K. Nathan
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-07 14:06:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Barry K. Nathan 2004-10-15 05:57:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a4)
Gecko/20040927

Description of problem:
I just happened to notice this dialog box, when I tried to set no
network devices to be "Active on Boot":

---begin quote---
Error With Data

You have no active network devices.  Your system will not be
able to communicate over a network by default without at least
one device active.

NOTE: If you have a PCMCIA-based network adapter you should leave it
inactive at this point. When you reboot your system the adapter will
be activated automatically.
---end quote---

The thing is, if I hadn't tried deactivating all network devices on
this system, I *never* would have seen anything in the installer about
keeping "Active on Boot" disabled for PCMCIA devices.

IMO the "Network Configuration" help should mention this somewhere.
Unless I'm *really* tired or something, I couldn't find it mentioned
anywhere in that help text.

Version-Release number of selected component (if applicable):
anaconda-help-10.0.4-1.noarch.rpm

How reproducible:
Always

Steps to Reproduce:
1. Start an fc-devel install.
2. At the "Network Configuration" screen, read through the help text.
3. Uncheck "Active on Boot" for all network devices.
4. Click "Next".
5. Read the dialog box.
    

Actual Results:  PCMCIA "Active on Boot" gotcha is mentioned only in
the dialog box.

Expected Results:  It should be mentioned in the "Network
Configuration" help text too.

Additional info:

I'm aware that it's (almost certainly) too late to fix this for FC3,
but if it could be fixed for FC4 I'd appreciate it. (BTW, is it too
late to fix this for RHEL4?)
Comment 1 Jeremy Katz 2005-09-21 14:22:44 EDT
I'm not sure how relevant some of this is with the new way PCMCIA is handled. 
Chris -- can you take a look
Comment 2 Chris Lumens 2006-06-07 14:06:02 EDT
This shouldn't be a problem with the more recent PCMCIA system.  In addition,
we've removed the help panel entirely because it wasn't ever very helpful and I
have removed the PCMCIA-specific portion of text from that error message so it
won't be misleading.

Note You need to log in before you can comment on or make changes to this bug.