Bug 135829 - no cd-rom icon is displayed on desktop after auto-mount of cdrom
no cd-rom icon is displayed on desktop after auto-mount of cdrom
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-15 06:10 EDT by Marius Andreiana
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-11 09:31:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (439.55 KB, image/png)
2004-10-15 06:13 EDT, Marius Andreiana
no flags Details

  None (edit)
Description Marius Andreiana 2004-10-15 06:10:44 EDT
Description of problem:
no cd-rom icon is displayed on desktop after auto-mount of cdrom. I
tried pressing ctrl+r in case of gamin bug.

Version-Release number of selected component (if applicable):
fc3t2
nautilus, gamin from rawhide:
nautilus-2.8.1-2
gamin-0.0.14-1

How reproducible:
100%

Steps to Reproduce:
1. insert cdrom
2. notice it is mounted (in terminal)
  
Actual results:
there's no icon on desktop, and Computer -> CDRW right-click has Mount
Volume, as it wasn't mounted. Double clicking on it makes desktop icon
appear, but also an error message that it's already mounted.
So, one cannot eject cd-rom from GUI,as icon it's not displayed from
the start.

Expected results:
display icon when cd is inserted
computer -> cdrw act as the cd is mounted (enable eject menu, not
Mount Volume)

Additional info:
I don't use autofs.
Preferences are set to open browser window on inserted media, which works.
See attached screenshot - nautilus browser automatically opened
(correct), Computer -> CD-RW which has mount option on right click,
instead of eject (print screen doesn't work with right click menu
opened, so it's not in screenshot).

Setting severity to High as regular end-user can't properly use CDROM.
Comment 1 Marius Andreiana 2004-10-15 06:13:10 EDT
Created attachment 105268 [details]
Screenshot
Comment 2 Alexander Larsson 2004-10-15 10:10:52 EDT
Can you try gnome-vfs2-2.8.2-4, it has a fix that *might* affect this.
Comment 3 Marius Andreiana 2004-10-17 05:54:25 EDT
I tried to use it, but it required newer udev,mkinitrd,hal, which
broke my system, posted on fedora-test.
Comment 4 Steven Van Impe 2004-11-09 09:46:15 EST
I have the same problem with a fresh FC3 install.
Also, upon login, the CD-RW icon appears as if a disc is loaded (which
is not the case).
Comment 5 Alexander Larsson 2005-01-11 09:17:21 EST
Does killall gnome-vfs-daemon fix it?
Comment 6 Marius Andreiana 2005-01-11 09:29:40 EST
worksforme in FC3 with all updates:
gnome-vfs2-2.8.2-8
gamin-0.0.19-1.FC3

Steven, can you confirm too? If yes, this should be closed. Thanks!
Comment 7 Marius Andreiana 2005-01-11 09:31:46 EST
I see Steven it's not CC'ed so he probably doesn't monitor this.
Closing as I'm original reporter.

Note You need to log in before you can comment on or make changes to this bug.