Bug 135831 - Please add "StartupNotify=true" in /usr/share/applications/xchat.desktop
Please add "StartupNotify=true" in /usr/share/applications/xchat.desktop
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xchat (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Reed
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-15 06:22 EDT by sangu
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-05 16:14:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description sangu 2004-10-15 06:22:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041012
Firefox/0.10.1

Description of problem:
Please add "StartupNotify=true" in
/usr/share/applications/xchat.desktop

Please see also : http://freedesktop.org/Software/startup-notification

Version-Release number of selected component (if applicable):
xchat-2.4.0-3

How reproducible:
Always

Steps to Reproduce:
1. Excute xchat in panel or menu.
2.
3.
    

Actual Results:  No circling mouse cursor icon(sand clock icon).

Expected Results:  Circling mouse cursor icon(sand clock icon).

Additional info:
Comment 1 Daniel Reed 2004-10-17 15:26:32 EDT
Guys, do you agree with this suggestion?
Comment 2 Bryan W Clark 2004-10-18 00:31:00 EDT
If xchat supports startup notification, then yes.  Not sure if it does
too much to just add the line to the desktop file if xchat doesn't
actually use it properly.  It might add a cursor during startup of the
app, but without xchat working with the startup-notification system
the cursor is just guessing.  Perhaps it's better to have it guessing
than nothing at all, a bug should be filed upstream about this if
xchat doesn't support startup-n.
Comment 3 Bryan W Clark 2004-12-13 15:27:08 EST
The question remaining here is: Does XChat support startup notification?
Comment 4 Havoc Pennington 2004-12-14 09:07:51 EST
This shouldn't be in NEEDINFO, since the info needed is something any
developer could investigate and find out, not info from the bug reporter.

Note You need to log in before you can comment on or make changes to this bug.