Bug 1358313 - the warning about initial status of the hosted-engine SD is confusing
Summary: the warning about initial status of the hosted-engine SD is confusing
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.HostedEngine
Version: 4.0.2
Hardware: Unspecified
OS: Unspecified
high
medium vote
Target Milestone: ovirt-4.0.5
: 4.0.5
Assignee: Yanir Quinn
QA Contact: Nikolai Sednev
URL:
Whiteboard: sla
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-20 13:40 UTC by Simone Tiraboschi
Modified: 2019-04-28 14:24 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-18 07:37:13 UTC
oVirt Team: SLA
rule-engine: ovirt-4.0.z+
ylavi: planning_ack+
dfediuck: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 62241 0 master MERGED core: Fix hosted engine SD initial status warning 2016-08-17 11:07:06 UTC
oVirt gerrit 62420 0 ovirt-engine-4.0 MERGED core: Fix hosted engine SD initial status warning 2016-08-17 13:46:28 UTC

Description Simone Tiraboschi 2016-07-20 13:40:15 UTC
Description of problem:
On fresh setup currently the engine emits a warning about the status of the hosted-engine storage domain: 'The Hosted Engine Storage Domain doesn't exist. It should be imported into the setup.'

This could be confusing and some users can think that they have to manually import it before proceeding.

Something like
'The Hosted Engine Storage Domain doesn't exist. It will be automatically imported when the datacenter goes up and this requires the first storage domain to be added.' could help since we already have different complains from users that try to manually import it without success.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. deploy hosted-engine
2. check engine warnings in the webui
3.

Actual results:
'The Hosted Engine Storage Domain doesn't exist. It should be imported into the setup.'

Expected results:
Something like 'The Hosted Engine Storage Domain doesn't exist. It will be automatically imported when the datacenter goes up and this requires the first storage domain to be added.'

Additional info:

Comment 1 Nikolai Sednev 2016-11-02 08:12:13 UTC
I see this message in UI:
The Hosted Engine Storage Domain doesn't exist. It will be imported automatically upon data center activation, which requires adding an initial storage domain to the data center.

Components on hosts:
rhev-release-4.0.5-5-001.noarch
sanlock-3.2.4-3.el7_2.x86_64
ovirt-setup-lib-1.0.2-1.el7ev.noarch
ovirt-vmconsole-host-1.0.4-1.el7ev.noarch
vdsm-4.18.15.2-1.el7ev.x86_64
libvirt-client-1.2.17-13.el7_2.6.x86_64
ovirt-hosted-engine-ha-2.0.4-1.el7ev.noarch
ovirt-imageio-common-0.3.0-0.el7ev.noarch
qemu-kvm-rhev-2.3.0-31.el7_2.23.x86_64
ovirt-hosted-engine-setup-2.0.3-2.el7ev.noarch
ovirt-host-deploy-1.5.3-1.el7ev.noarch
ovirt-engine-sdk-python-3.6.9.1-1.el7ev.noarch
ovirt-imageio-daemon-0.4.0-0.el7ev.noarch
ovirt-vmconsole-1.0.4-1.el7ev.noarch
mom-0.5.8-1.el7ev.noarch
rhevm-appliance-20160922.0-1.el7ev.noarch
Linux version 3.10.0-327.36.3.el7.x86_64 (mockbuild@x86-037.build.eng.bos.redhat.com) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-4) (GCC) ) #1 SMP Thu Oct 20 04:56:07 EDT 2016
Linux 3.10.0-327.36.3.el7.x86_64 #1 SMP Thu Oct 20 04:56:07 EDT 2016 x86_64 x86_64 x86_64 GNU/Linux
Red Hat Enterprise Linux Server release 7.2 (Maipo)

Components on engine:
ovirt-engine-dwh-4.0.5-1.el7ev.noarch
ovirt-engine-dwh-setup-4.0.5-1.el7ev.noarch
ovirt-vmconsole-proxy-1.0.4-1.el7ev.noarch
eap7-wildfly-web-console-eap-2.8.27-1.Final_redhat_1.1.ep7.el7.noarch
ovirt-vmconsole-1.0.4-1.el7ev.noarch
ovirt-engine-vmconsole-proxy-helper-4.0.5.4-0.1.el7ev.noarch
ovirt-engine-setup-plugin-vmconsole-proxy-helper-4.0.5.4-0.1.el7ev.noarch
qemu-guest-agent-2.3.0-4.el7.x86_64
rhevm-guest-agent-common-1.0.12-3.el7ev.noarch
rhevm-spice-client-x64-msi-4.0-3.el7ev.noarch
rhevm-branding-rhev-4.0.0-5.el7ev.noarch
rhevm-dependencies-4.0.0-1.el7ev.noarch
rhev-release-4.0.5-5-001.noarch
rhevm-spice-client-x86-msi-4.0-3.el7ev.noarch
rhevm-4.0.5.4-0.1.el7ev.noarch
rhevm-guest-agent-common-1.0.12-3.el7ev.noarch
rhevm-setup-plugins-4.0.0.3-1.el7ev.noarch
rhev-guest-tools-iso-4.0-6.el7ev.noarch
rhevm-doc-4.0.5-1.el7ev.noarch
Linux version 3.10.0-327.36.1.el7.x86_64 (mockbuild@x86-037.build.eng.bos.redhat.com) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-4) (GCC) ) #1 SMP Wed Aug 17 03:02:37 EDT 2016
Linux 3.10.0-327.36.1.el7.x86_64 #1 SMP Wed Aug 17 03:02:37 EDT 2016 x86_64 x86_64 x86_64 GNU/Linux
Red Hat Enterprise Linux Server release 7.2 (Maipo)


Note You need to log in before you can comment on or make changes to this bug.