Bug 135849 - no default X11 forwarding or broken with RHEL3 and other UNIX
no default X11 forwarding or broken with RHEL3 and other UNIX
Status: CLOSED DUPLICATE of bug 137685
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: openssh (Show other bugs)
4.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-15 08:24 EDT by Uwe Beck
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-31 16:30:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Uwe Beck 2004-10-15 08:24:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.4.3)
Gecko/20040924

Description of problem:
X11 forwarding was always default in /etc/ssh/ssh_config.
Since openssh 3.8 there are some new parameters for X11 forwarding needed.

Typical problem:

1. Error: Can't open display:
 -> resolution in /etc/ssh/ssh_config
Host *
        ForwardX11 yes

2. connect to RHEL3 or other UNIX
X Error of failed request:  BadDrawable (invalid Pixmap or Window
parameter)
  Major opcode of failed request:  73 (X_GetImage)
  Resource id in failed request:  0x48
  Serial number of failed request:  184
  Current serial number in output stream:  184

-> resolution in /etc/ssh/ssh_config
Host *
        ForwardX11 yes
        ForwardX11Trusted yes

With this parameters you can connect to all other systems and X11
forwarding works as default.


Version-Release number of selected component (if applicable):
openssh-clients-3.9p1-3

How reproducible:
Sometimes

Steps to Reproduce:
1. connect with ssh to other systems than RHEL4_BETA1
2. start a X11 program
3.
    

Actual Results:  X11 forwarding is not available by default

Expected Results:  X11 forwarding should be available by default

Additional info:

The new ssh_config parameters already comes with openssh version 3.8.
Comment 1 Barry K. Nathan 2004-10-17 22:28:55 EDT
> -> resolution in /etc/ssh/ssh_config
> Host *
>         ForwardX11 yes
>         ForwardX11Trusted yes

Very Bad Idea(tm). X11 forwarding is being disabled by default because
automatically doing it by default is insecure. (Red Hat should have
changed their default to the upstream default a long time ago, but at
least they're doing the right thing now.)

Users can use the -X and -Y options to ssh as needed, or configuration
files can be changed to automatically enable X11 forwarding on a
per-host basis.
Comment 2 Tomas Mraz 2005-01-31 16:29:03 EST

*** This bug has been marked as a duplicate of 137685 ***

Note You need to log in before you can comment on or make changes to this bug.