Bug 1358557 - the task icons are not updated when using the recipe task anchors
Summary: the task icons are not updated when using the recipe task anchors
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: web UI   
(Show other bugs)
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
urgent vote
Target Milestone: 24.0
Assignee: matt jia
QA Contact: tools-bugs
URL:
Whiteboard:
Keywords: FutureFeature, Patch
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-21 00:35 UTC by matt jia
Modified: 2017-02-21 18:49 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 1293007
Environment:
Last Closed: 2017-02-21 18:49:20 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description matt jia 2016-07-21 00:35:18 UTC
Description of problem:

The task icon is not updated when visiting a recipe page with a recipe task anchor in the url.


How reproducible:

Easy

Steps to Reproduce:
1. go to a recipe page with a task icon.
2. check the expanded task icon
Actual results:

The icon is not updated

Expected results:

The icon should be updated by using the fa-caret-down icon.

Comment 1 matt jia 2016-07-21 00:36:57 UTC
(In reply to matt jia from comment #0)
> Description of problem:
> 
> The task icon is not updated when visiting a recipe page with a recipe task
> anchor in the url.
> 
> 
> How reproducible:
> 
> Easy
> 
> Steps to Reproduce:
> 1. go to a recipe page with a task icon.

Oops, a typo, I meant a task anchor.

Comment 2 matt jia 2016-07-21 00:37:28 UTC
On Gerrit:

   https://gerrit.beaker-project.org/#/c/5065/

Comment 4 Dan Callaghan 2016-08-31 05:33:48 UTC
This requires some style tweaks in order to make it look right:

https://gerrit.beaker-project.org/5177

However that patch doesn't work with less 1.4 (I was accidentally testing with less 1.7 which is the current version in EPEL6).

Since this is not really an urgent fix at all, I would rather bump this bug to 24.0. We can re-apply the patch, including the style fixes and a requirement on the newer nodejs-less, which we can get built in eng-rhel-6 at our leisure.

Comment 5 Dan Callaghan 2016-09-02 02:56:09 UTC
http://gerrit.beaker-project.org/5181

This is Matt's original patch, plus my style tweaks, plus a requirement on nodejs-less >= 1.7. That will fail right now, until we get a newer version of nodejs-less built.

Comment 7 wangdong 2016-09-22 07:06:15 UTC
Verify passed on https://beaker-devel.app.eng.bos.redhat.com/

Steps:
1. Got recipe page.
2. Click on task anchors to expend task.
3. Check anchors is update


Change status to verified.

Comment 8 Dan Callaghan 2017-02-21 18:49:20 UTC
Beaker 24.0 has been released.


Note You need to log in before you can comment on or make changes to this bug.