Bug 1358594 - Enable gfapi test cases in Gluster upstream regression
Summary: Enable gfapi test cases in Gluster upstream regression
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tests
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Poornima G
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1375990
TreeView+ depends on / blocked
 
Reported: 2016-07-21 05:11 UTC by Poornima G
Modified: 2017-03-27 18:21 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.9.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1375990 (view as bug list)
Environment:
Last Closed: 2017-03-27 18:21:04 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Poornima G 2016-07-21 05:11:10 UTC
Description of problem:
As of now all the libgfapi test cases are disabled, as the compile of libgfapi applications was failing on regression system. On regression system, the gluster instance, on which the regression needs to be run, is on chroot location: /build/install/. While compiling gfapi applications, the header files and .so files are looked up on the standard locations, and hence fails. To fis this one of the below things can be done:
1. Define CPATH and LIBRARY_PATH in env.rc
2. Define PKG_CONFIG_PATH in env.rc and use the location specified in glusterfs-api.pc to find the *.h and *.so files.

Both the things are implemented in the patch http://review.gluster.org/#/c/14748

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Vijay Bellur 2016-07-21 05:12:48 UTC
REVIEW: http://review.gluster.org/14748 (tests: Enable all gfapi test cases) posted (#27) for review on master by Poornima G (pgurusid@redhat.com)

Comment 2 Vijay Bellur 2016-07-21 06:15:59 UTC
COMMIT: http://review.gluster.org/14748 committed in master by Raghavendra Talur (rtalur@redhat.com) 
------
commit 0a8b85e3a8228c399dde807c3ca781a452a1fc90
Author: Poornima G <pgurusid@redhat.com>
Date:   Fri Jun 17 01:27:31 2016 -0400

    tests: Enable all gfapi test cases
    
    Change-Id: I32bfec4af91348d96dc3e81a9d5c9cad599f821b
    Bug: 1358594
    Signed-off-by: Poornima G <pgurusid@redhat.com>
    Reviewed-on: http://review.gluster.org/14748
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra Talur <rtalur@redhat.com>

Comment 3 Vijay Bellur 2016-07-25 05:10:02 UTC
REVIEW: http://review.gluster.org/14997 (tests: Fix the spurious failure in libgfapi-fini-hang.t) posted (#1) for review on master by Poornima G (pgurusid@redhat.com)

Comment 4 Vijay Bellur 2016-07-25 05:29:52 UTC
REVIEW: http://review.gluster.org/14997 (tests: Fix the spurious failure in libgfapi-fini-hang.t) posted (#2) for review on master by Poornima G (pgurusid@redhat.com)

Comment 5 Vijay Bellur 2016-07-25 06:37:14 UTC
REVIEW: http://review.gluster.org/14997 (tests: Fix the spurious failure in libgfapi-fini-hang.t) posted (#3) for review on master by Poornima G (pgurusid@redhat.com)

Comment 6 Vijay Bellur 2016-07-25 20:14:52 UTC
REVIEW: http://review.gluster.org/14997 (tests: Fix the spurious failure in libgfapi-fini-hang.t) posted (#4) for review on master by Vijay Bellur (vbellur@redhat.com)

Comment 7 Vijay Bellur 2016-07-26 12:59:15 UTC
REVIEW: http://review.gluster.org/14997 (tests: Fix the spurious failure in libgfapi-fini-hang.t) posted (#5) for review on master by Poornima G (pgurusid@redhat.com)

Comment 8 Vijay Bellur 2016-07-27 04:37:33 UTC
REVIEW: http://review.gluster.org/14997 (tests: Fix the spurious failure in libgfapi-fini-hang.t) posted (#6) for review on master by Poornima G (pgurusid@redhat.com)

Comment 9 Vijay Bellur 2016-07-27 16:29:33 UTC
COMMIT: http://review.gluster.org/14997 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit 4e1ad2c96ea692e49fb82ce533cdc26818277e8d
Author: Poornima G <pgurusid@redhat.com>
Date:   Mon Jul 25 10:26:58 2016 +0530

    tests: Fix the spurious failure in libgfapi-fini-hang.t
    
    RCA:
    After running libgfapi-fini-hang, there is a EXPECT_WITHIN which waits
    for PROCESS_UP_TIMEOUT(20s), for the process libgfapi-fini-hang to die.
    Currently EXPECT_WITHIN is returning success even if the process
    libgfapi-fini-hang is alive. This is because "pgrep libgfapi-fini-hang"
    in check_process() is returning 1(no process alive) even if the process
    is alive. Man page of pgrep says "The process name used for matching is
    limited to the 15 characters". Hence changing the name of executable from
    libgfapi-fini-hang to gfapi-hang, so that it falls within the limit.
    
    As explained the failure is not because there was a hang(logs show that
    glfs_set_volfile_server was still executing), but because EXPECT_WITHIN
    was not really waiting. And hence there was a race between the execution
    of the process libgfapi-fini-hang and the kill.
    
    Change-Id: I257715865e0d3e5a14f83d1e235c01899e1cae68
    BUG: 1358594
    Signed-off-by: Poornima G <pgurusid@redhat.com>
    Reviewed-on: http://review.gluster.org/14997
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.org>

Comment 10 Shyamsundar 2017-03-27 18:21:04 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.0, please open a new bug report.

glusterfs-3.9.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2016-November/029281.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.