Bug 1358599 - [Docs] Update HE setup documentation for RHEV 3.5 with specific version of ovirt-hosted-engine-setup (1.2.x)
Summary: [Docs] Update HE setup documentation for RHEV 3.5 with specific version of ov...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation
Version: 3.5.7
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
: ---
Assignee: Julie
QA Contact: rhev-docs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-21 06:10 UTC by Germano Veit Michel
Modified: 2019-12-16 06:09 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-31 11:58:25 UTC
oVirt Team: Docs
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2456071 0 None None None 2016-07-21 07:08:29 UTC

Description Germano Veit Michel 2016-07-21 06:10:02 UTC
Description of problem:

In both links

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.5/html/Installation_Guide/Installing_the_Self-Hosted_Engine.html

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.5/html/Installation_Guide/Installing_Additional_Hosts_to_a_Self-Hosted_Environment.html

We suggest running 'yum install ovirt-hosted-engine-setup'. But this will get latest 1.3.x packages for ovirt-hosted-engine, which are intended for RHEV 3.6, and host deployment will fail.

RHEV 3.5 uses 1.2.x packages, and customers can still deploy fresh additional hosts. So we should include a more specific yum install command, for example 'yum install ovirt-hosted-engine-ha-1.2.10-1.el7ev ovirt-hosted-engine-setup-1.2.6.1-1.el7'

Version-Release number of selected component (if applicable):
rhevm-3.5.8

Comment 1 Marina Kalinin 2016-07-21 22:06:11 UTC
Hi Germano,

We are working on this process right now with Eng and Docs.
Once it will be fully acked by Eng and QE, we will update the documentation.

https://bugzilla.redhat.com/show_bug.cgi?id=1328382#c26

Closing this bug as a duplicate of the above.

*** This bug has been marked as a duplicate of bug 1328382 ***

Comment 2 Marina Kalinin 2016-07-21 22:13:57 UTC
Also, for my understanding, 3.5 docs would not be updated, since for the upgrade to next version they should look into next version documentation. I.e. 3.6. And this is what the duplicate bug is going to address.

Comment 3 Germano Veit Michel 2016-07-21 23:10:10 UTC
Hi Marina,

Maybe I wasn't clear enough in the bug description. This has NOTHING to do with RHEV 3.6 Upgrade.

One can use 3.5, NOT upgrade to 3.6 and want to deploy additional RHEL hosts. We do have customer who will not upgrade to 3.6 (browser support for example).

Deploying fresh additional hosts in 3.5 fails today because our RHEV 3.5 manual states 'yum install ovirt-hosted-engine-setup', which will pull 3.6 packages.

I am afraid the only solution is to update the 3.5 manual and clearly state the correct versions for 3.5. Not related to any 3.6 or upgrade manual.

Or do we want new 3.5 HE installs running 1.3.x packages? I am missing something?

Reopening for now.

Comment 4 Marina Kalinin 2016-07-22 18:58:30 UTC
Germano,
You are saying that today there is no way to add anew RHEL7 host to 3.5 HE setup, right?

I think we should create a kcs saying that for such a scenario latest RHEV-H 3.5 should be used. And in order to use RHEL, upgrade to 3.6 is required.
I think this is a reasonable suggestion.
Can you please create such a kcs?

Provide this link for download:
https://access.redhat.com/downloads/content/150/ver=3.5/rhel---6/3.5/x86_64/product-software

Comment 5 Germano Veit Michel 2016-07-24 23:24:14 UTC
Marina, correct. 

If one follows the current documentation for a fresh additional host deployment, it fails.

I'm not sure if we should force customers to use RHEV-H in this case. We are not updating RHEV-H images for 3.5 anymore, so they are getting old and not receiving fixes.

Also, the same problem shows up here. A fresh 3.5 install fails due to the same reason:
https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.5/html/Installation_Guide/Installing_the_Self-Hosted_Engine.html

And yes, we not only have lots of customers using 3.5, but also customers fresh installing RHEV 3.5. It's a supported version and we must keep it's documentation in good shape.

Comment 6 Germano Veit Michel 2016-07-24 23:41:58 UTC
Marina, that only contains the RHEL 6 RHEV-H image. 

So I added this to the KCS https://access.redhat.com/downloads/content/150/ver=/rhel---7/7.2/x86_64/product-software

I updated the original KCS (attached to this BZ to reflect this). Still, I believe our docs must be updated as well, as they are now broken due to delivering 3.6 packages in same repo as 3.5.


Note You need to log in before you can comment on or make changes to this bug.