Bug 135862 - please don't use fixed width pages
please don't use fixed width pages
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.18
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: David Lawrence
David Lawrence
http://www.uiwizards.com/wBloop23.html
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-15 11:04 EDT by Mike McLean
Modified: 2007-04-18 13:13 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-08 15:39:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McLean 2004-10-15 11:04:02 EDT
Fixed width pages assume that all browsers are running about about the same
resolution with about the same font size, but this is not the case.

The current fixed width causes inconvenience when
  - users are using large fonts (perhaps for accessibility or because the user
is also using very high resolution).
  - users are using small browsers windows (perhaps because they just don't want
the browser to eat so much of their screen or because their screen resolution is
small).
Comment 1 Mike McLean 2004-10-15 11:11:40 EDT
You can moderate one-half of the problem by using a font-size relative width
specification (em).  For example

http://www.maxdesign.com.au/presentation/em/em.htm
http://www.cednc.org/programs/engage/finance/

This still leaves 800x600 browser windows in scrollbar territory.  I don't know
if there's a way solve that without dropping fixed-width entirely.
Comment 2 David Lawrence 2004-10-26 16:59:29 EDT
Ok set the use of min-width which I didnt know about. Does it look better now
when changing browser size?
Comment 3 Mike McLean 2004-10-26 18:15:57 EDT
It certainly helps on the large window end.  800x600 still has to scroll.

It might be better to specify min-width in a font-relative way (units: em or ex).
Comment 4 Mike McLean 2005-04-08 15:39:06 EDT
closing

Note You need to log in before you can comment on or make changes to this bug.