Bug 13587 - LDs on aacraid ignored by beta3 installer as 'removable'.
LDs on aacraid ignored by beta3 installer as 'removable'.
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Depends On:
  Show dependency treegraph
Reported: 2000-07-07 17:49 EDT by Matt Domsch
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-07-27 11:46:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Matt Domsch 2000-07-07 17:49:34 EDT
Logical drives on aacraid-based controllers are ignored by the installer 
because the disks are flagged "removable" by the driver.

Using the driver disk I created for the aacraid driver, (and hitting 
Cancel after a couple passes through the "Please insert your driver disk 
labeled ... again, again, again", it loaded the aacraid driver. However, 
later I hit the message "no valid devices were found on which to create 
new filesystems". Going to Alt-F3, I see the messages "Not in expert mode, 
ignoring removable device sd[abc]".

Adaptec has set the removable device flag on the aacraid-controlled 
devices, because while the system is running, root may use a management 
app to add or delete a virtual drive.
Comment 1 Matt Domsch 2000-07-21 17:53:02 EDT
Beta 4 exhibits the same problem.  msw's testblacklist program doesn't seem to 
be working as expected.
Comment 2 Matt Wilson 2000-07-24 23:11:54 EDT
Will be fixed in beta5
Comment 3 Matt Domsch 2000-07-27 11:46:17 EDT
Fixed in beta 5.  Expert mode no longer necessary to install onto aacraid disks.

Note You need to log in before you can comment on or make changes to this bug.