Bug 1358722 - Integration of Manila support of Externally Deployed Ceph Cluster with OSPd
Summary: Integration of Manila support of Externally Deployed Ceph Cluster with OSPd
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ga
: 10.0 (Newton)
Assignee: Erno Kuvaja
QA Contact: Dustin Schoenbrun
Don Domingo
URL:
Whiteboard:
Depends On:
Blocks: 1364096
TreeView+ depends on / blocked
 
Reported: 2016-07-21 11:29 UTC by Jeff Brown
Modified: 2016-12-14 15:46 UTC (History)
14 users (show)

Fixed In Version: openstack-tripleo-heat-templates-5.0.0-0.20160929150845.4cdc4fc.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 15:46:52 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 188137 None None None 2016-08-08 20:02:11 UTC
OpenStack gerrit 353928 None None None 2016-08-19 12:12:03 UTC
OpenStack gerrit 354047 None None None 2016-08-19 12:11:20 UTC
OpenStack gerrit 358525 None None None 2016-08-22 10:00:20 UTC

Description Jeff Brown 2016-07-21 11:29:43 UTC
Description of problem:

Support of Manilla default drivers is moving upstream. We need to support the inclusion of Ceph Manilla support as well.

Refer to:
https://review.openstack.org/#/c/188137/64

We need to include the patches to enable Ceph vs. the default Manila driver.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 seb 2016-08-10 14:17:42 UTC
Looks like the initial integration of Manila got merged upstream.
Do we have any equivalent yet when it comes to the integration of the cephfs driver?

Comment 3 Erno Kuvaja 2016-08-10 14:24:18 UTC
I will hopefully have changes ready for review in upstream shortly. Currently working on this.

Comment 4 Erno Kuvaja 2016-08-22 10:00:21 UTC
Adding the last change needed, tht.

Comment 5 Erno Kuvaja 2016-08-29 09:43:09 UTC
puppet-tripleo change merged. THT to go.

Comment 17 Tom Barron 2016-12-13 14:46:58 UTC
Changed the title to reflect what was actually requested as an OSP10 deliverable.

Comment 19 errata-xmlrpc 2016-12-14 15:46:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.