Bug 135874 - Folder with non-ascii chars in name dragged to panel can't be opened
Folder with non-ascii chars in name dragged to panel can't be opened
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks: 131589
  Show dependency treegraph
 
Reported: 2004-10-15 11:53 EDT by Kristian Høgsberg
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-16 01:32:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kristian Høgsberg 2004-10-15 11:53:46 EDT
Description of problem:
Dragging a nautilus folder icon to the panel will create a launcher to
open the folder.  However if the name of the folder has non-ascii
chars in it the launcher doesn't work, since the folder name vfs URI
get's quoted.

Version-Release number of selected component (if applicable):
gnome-panel-2.8.0.1-3
nautilus-2.8.1-1

How reproducible:
Always

Steps to Reproduce:
1. Create folder with non-ascii (eg. "ø") in the name
2. Drag nautilus folder icon to panel
3. Try to open the folder from the panel
  
Actual results:
Folder doesn't open, insted error dialog is shown:

  Couldn't find "/home/bongo/Desktop/C3B8"

Expected results:
Folder should open.

Additional info:
Comment 1 Matthias Clasen 2004-10-15 17:03:19 EDT
Hmm, the problem is that the panel apparently interprets %f etc in the
commandline. One possible fix would be to escape the % in the uri to %%.
Another solution would be to instead of creating an Application
lauchcher with cmdline nautilus -- 'uri', create a Link launcher with
just the given uri.
Comment 2 Kristian Høgsberg 2004-10-16 01:32:49 EDT
As of gnome-panel-2.8.1-2, I can no longer reproduce the bug.  Closing.

Note You need to log in before you can comment on or make changes to this bug.