Bug 135886 - Reading data off block device from USB memory stick fails
Summary: Reading data off block device from USB memory stick fails
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: hal   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC3Blocker
TreeView+ depends on / blocked
 
Reported: 2004-10-15 17:04 UTC by David Zeuthen
Modified: 2013-03-06 03:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-15 22:25:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from hald on .624 when plugging in USB memory stick (19.90 KB, text/plain)
2004-10-15 17:05 UTC, David Zeuthen
no flags Details
Selected strace output from hald on .624 when plugging in USB memory stick (2.85 KB, text/plain)
2004-10-15 17:06 UTC, David Zeuthen
no flags Details
Output from hald on .584 when plugging in USB memory stick (3.92 KB, text/plain)
2004-10-15 17:07 UTC, David Zeuthen
no flags Details
Selected strace output from hald on .584 when plugging in USB memory stick (2.61 KB, text/plain)
2004-10-15 17:07 UTC, David Zeuthen
no flags Details

Description David Zeuthen 2004-10-15 17:04:12 UTC
Description of problem:

Reading data off a block device from a USB memory stick fails. This
means that the hal daemon cannot probe for file system type, volume
labels, UUID and so forth. Reading data off IDE devices appear to work.

Version-Release number of selected component (if applicable):

2.6.8-1.624

This worked with earlier kernels, I've just tested with .610 and .584.

How reproducible:

Always.

Steps to Reproduce:
1. Start up hal daemon 
2. Plugin a USB stick
3. Verify with hal-device-manager that volume.fstype, volume.label
isn't set.
  
Additional info:

Will attach strace and debug output from hald from runs on the .624
and the .610 kernel

Comment 1 David Zeuthen 2004-10-15 17:05:53 UTC
Created attachment 105284 [details]
Output from hald on .624 when plugging in USB memory stick

Comment 2 David Zeuthen 2004-10-15 17:06:41 UTC
Created attachment 105285 [details]
Selected strace output from hald on .624 when plugging in USB memory stick

Comment 3 David Zeuthen 2004-10-15 17:07:11 UTC
Created attachment 105286 [details]
Output from hald on .584 when plugging in USB memory stick

Comment 4 David Zeuthen 2004-10-15 17:07:53 UTC
Created attachment 105287 [details]
Selected strace output from hald on .584 when plugging in USB memory stick

Comment 5 David Zeuthen 2004-10-15 17:10:48 UTC
The difference seems to be that read(2) on the fd from /dev/sda1 fails
with EAGAIN (aka EWOULDBLOCK). Is this a bug in the application?

Comment 6 David Zeuthen 2004-10-15 17:12:51 UTC
I'm here in the Westford office if you need more traces, info etc.

Comment 7 David Zeuthen 2004-10-15 20:28:33 UTC
OK, as discussed on IRC the kernel update just exposes already flawed
apps wrt. using O_NONBLOCK. I've got a patch that I will apply to the
hal package to fix this.

Reassigning this bug to hal.

Comment 8 David Zeuthen 2004-10-15 22:25:19 UTC
This is fixed in hal-0.4.0-3


Note You need to log in before you can comment on or make changes to this bug.