Bug 135889 - Kernel panic when booting after upgrading from kernel-2.6.8-1.541
Summary: Kernel panic when booting after upgrading from kernel-2.6.8-1.541
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 3
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-15 17:16 UTC by Henning Norén
Modified: 2015-01-04 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-15 19:47:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Henning Norén 2004-10-15 17:16:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041012
Firefox/0.10.1

Description of problem:
during boot of new kernel 2.6.8-1.610 or 2.6.8-1.624 kernel panic occurs.

Messages handwritten of screen follows (ignore spellingerrors):

creating /dev
starting udev
loading dm-mod.ko module
device-mapper: 4.1.0-ioctl(2003-12-10) initialised: dm@uk.sistina.com
Loading jbd.ko module
Loading ext3.ko module
Loading dm-mirror.ko module
Loading dm-zero.ko module
Loading dm-snapshot.ko module
Making device-mapper control node
Scanning logical volumes
  Reading all physical volumes. This may take a while...
  Found volumegroup "VolGroup00" using metadata type lvm2
Activating logical volumes
  2 logical volume(s) in volume group "VolGroup00" now active
Making device nodes
Creating root device
Mounting root filesystem
mount: error 6 mounting ext3
mount: error 2 mounting none
Switching to new root
switchroot: mount failed 22
umount /initrd/dev/failed: 2
kernel panic - not syncing: Attempting to kill init.


Same problem on both 2.6.8-1.610 and 2.6.8-1.624.
Kernel 2.6.8-1.541 (default on FC3-T3) works fine.

I have tried running mkinitrd with both 610 and 624, and although it
produces a different (according to diff) initrd-file than the one
created on install it will not boot.
Installation of kernels through yum and up2date.


Version-Release number of selected component (if applicable):
kernel 2.6.8-1.610, kernel 2.6.8-1.624

How reproducible:
Always

Steps to Reproduce:
1. Boot system with kernel 2.6.8-1.610 or 2.6.8-1.624
    

Actual Results:  Kernel Panic

Expected Results:  Complete boot

Additional info:

Grub.conf entry (kernel 2.6.8-1.610 is removed):

default=0
timeout=10
splashimage=(hd0,0)/grub/splash.xpm.gz
title Fedora Core (2.4.22-1.2199.nptl)
        root (hd0,0)
        kernel /vmlinuz-2.4.22-1.2199.nptl ro root=LABEL=/1 rhgb
        initrd /initrd-2.4.22-1.2199.nptl.img
title Fedora Core 3
        root (hd1,0)
        kernel /vmlinuz-2.6.8-1.541
        initrd /initrd-2.6.8-1.541.img
title Fedora Core 3 (Kernel 2.6.8-1.624)
        root (hd1,0)
        kernel /vmlinuz-2.6.8-1.624
        initrd /initrd-2.6.8-1.624.img


Application versions that might be of interest:
mkinitrd-4.1.15-1
gawk-3.1.3-9
kernel-2.6.8-1.541
kernel-2.6.8-1.624

Comment 1 Bill Nottingham 2004-10-15 19:35:34 UTC
You need a root=LABEL=/1 (or similar) on the 'kernel' lines.

Comment 2 Henning Norén 2004-10-15 19:46:43 UTC
Ouch, silly me. 

Now it works (although hal-0.4.0-2 seems to bug out on the new kernel,
but that is another bug) so please close this.


Note You need to log in before you can comment on or make changes to this bug.