Bug 1358898 - Failed to create dc using xpaas template apps
Summary: Failed to create dc using xpaas template apps
Keywords:
Status: CLOSED DUPLICATE of bug 1357668
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Templates
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Ben Parees
QA Contact: XiuJuan Wang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-21 17:47 UTC by Vikas Laad
Modified: 2016-07-21 17:53 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-21 17:53:57 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Vikas Laad 2016-07-21 17:47:45 UTC
Description of problem:
When trying to deploy eap app on Openshift 3.3 using xpaas-templates DeploymentConfig fails to create because of following error. Template needs to be updated.

    error: DeploymentConfig "eap-app" is invalid: spec.triggers[0].imageChangeParams.from.name: Invalid value: "eap-app": must be in the form of <name>:<tag>

Version-Release number of selected component (if applicable):
openshift v3.3.0.8
kubernetes v1.3.0+57fb9ac
etcd 2.3.0+git

How reproducible:
Always on Openshift 3.3

Steps to Reproduce:
1. Create an env with openshift v3.3
2. Create a new app using eap64-mysql-s2i
3. see the error 

Actual results:
    error: DeploymentConfig "eap-app" is invalid: spec.triggers[0].imageChangeParams.from.name: Invalid value: "eap-app": must be in the form of <name>:<tag>


Expected results:
DeploymentConfig should be created and app should be created.

Additional info:

Comment 1 Ben Parees 2016-07-21 17:53:57 UTC

*** This bug has been marked as a duplicate of bug 1357668 ***


Note You need to log in before you can comment on or make changes to this bug.