Bug 1358930 - OSE Deployment Failure during post_install.yml: configure iptables to allow for NFS shares: stderr: iptables: No chain/target/match by that name.
Summary: OSE Deployment Failure during post_install.yml: configure iptables to allow f...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: Installation - RHEV
Version: 1.0
Hardware: All
OS: All
urgent
urgent
Target Milestone: ga
: 1.0
Assignee: John Matthews
QA Contact: Landon LaSmith
Dan Macpherson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-21 19:38 UTC by Landon LaSmith
Modified: 2016-09-13 16:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-13 16:33:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1358951 None None None Never
Red Hat Product Errata RHEA-2016:1862 normal SHIPPED_LIVE Red Hat Quickstart Installer 1.0 2016-09-13 20:18:48 UTC

Internal Links: 1358951

Description Landon LaSmith 2016-07-21 19:38:25 UTC
Description of problem: 
OSE deployment of RHEV fails during the post_install ansible playbook execution of task [configure iptables to allow for NFS shares] with error: "stderr: iptables: No chain/target/match by that name."


ISO Media Version: QCI-1.2-RHEL-7-20160720.t.0


How reproducible: 100%


Steps to Reproduce:
1. Install QCI
2. Deploy RHEV+OSE(+CFME)

Actual results: Deployment fails at 95% during OSE deployment w/ message "ansible-playbook returned a non-zero exit code during post-installation. Please refer to the log for more information regarding the failure."

Deployment log reports "ansible: executing /opt/theforeman/tfm/root/usr/share/gems/gems/fusor_server-1.0.0/lib/modules/ose_installer/playbooks/post_install.yml with /usr/share/foreman/tmp/BQqcpVcYHB/ansible.hosts"

ansible.log reports:

2016-07-21 00:28:59,204 p=12096 u=foreman |  TASK: [configure iptables to allow for NFS shares] ****************************
2016-07-21 00:28:59,463 p=12096 u=foreman |  failed: [jwm1-ose-node1.example.com] => {"changed": true, "cmd": ["iptables", "-I", "OS_FIREWALL_ALLOW", "-p", "tcp", "-m", "state", "--state", "NEW", "-m", "tcp", "--dport", "2049", "-j", "ACCEPT"], "delta": "0:00:00.009415", "end": "2016-07-21 04:28:59.054795", "rc": 1, "start": "2016-07-21 04:28:59.045380", "warnings": []}
2016-07-21 00:28:59,463 p=12096 u=foreman |  stderr: iptables: No chain/target/match by that name.

Expected results: OSE deployment succeeds

Comment 2 John Matthews 2016-07-22 06:49:53 UTC
Root cause was answer file format changed for OSE 3.2.
Appears to be an unattended consequence causing older format to no longer work.
Filed BZ with OCP at BZ 1358951

Comment 3 John Matthews 2016-07-25 19:21:31 UTC
https://github.com/fusor/fusor/pull/1079

Comment 4 Landon LaSmith 2016-08-12 13:14:46 UTC
VERIFIED. I was able to deploy OpenShift successfully with no issues during the same task

QCI ISO media version: QCI-1.0-RHEL-7-20160809.t.0

2016-08-09 20:02:09,448 p=5633 u=foreman |  TASK: [configure iptables to allow for NFS shares] **************************** 
2016-08-09 20:02:09,589 p=5633 u=foreman |  changed: [cjqyhzwdzu-ose-node1.lab.eng.rdu2.redhat.com] => {"changed": true, "cmd": ["iptables", "-I", "OS_FIREWALL_ALLOW", "-p", "tcp", "-m", "state", "--state", "NEW", "-m", "tcp", "--dport", "2049", "-j", "ACCEPT"], "delta": "0:00:00.004150", "end": "2016-08-10 00:02:10.035745", "rc": 0, "start": "2016-08-10 00:02:10.031595", "stderr": "", "stdout": "", "warnings": []}

Comment 6 errata-xmlrpc 2016-09-13 16:33:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862


Note You need to log in before you can comment on or make changes to this bug.