Bug 1359046 - Python3 subpackage for python-txzmq
Summary: Python3 subpackage for python-txzmq
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-txzmq   
(Show other bugs)
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Fedora Infrastructure SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks: PYTHON3 PY3PATCH-AVAILABLE
TreeView+ depends on / blocked
 
Reported: 2016-07-22 07:38 UTC by Lumír Balhar
Modified: 2016-08-27 10:45 UTC (History)
3 users (show)

Fixed In Version: python-txzmq-0.7.4-5.git772df64.fc25
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-27 10:45:09 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
specfile patch (3.55 KB, application/mbox)
2016-07-22 07:38 UTC, Lumír Balhar
no flags Details
Rebased patch (3.86 KB, patch)
2016-07-26 07:16 UTC, Lumír Balhar
no flags Details | Diff
Fixed issue in release number (3.89 KB, patch)
2016-07-30 18:50 UTC, Lumír Balhar
no flags Details | Diff
Fixing changelog (665 bytes, patch)
2016-08-04 15:37 UTC, Lumír Balhar
no flags Details | Diff

Description Lumír Balhar 2016-07-22 07:38:28 UTC
Created attachment 1182729 [details]
specfile patch

Hello.

I've created patch for python-txzqm specfile which enables python3 subpackage. There are some Py3 incompatibility issues in current release so I need to change source for this package to last commit on GitHub. I've also created issue on GitHub but without response from developers. [0]

I've also removed "0001-Disable-epgm-test.patch" because it doesn't fit for latest version and tests during build looks ok without it.

I've tested it in mock (build, installation, import in Python CLI) and in Koji (build). [1]

Could you please test this new package and push this changes? TxZMQ is in dependency tree for some important packages so it will move porting forward.

Thank you and have a nice day.

[0] https://github.com/smira/txZMQ/issues/68
[1] http://koji.fedoraproject.org/koji/taskinfo?taskID=14977571

Comment 1 Kevin Fenzi 2016-07-23 23:01:14 UTC
Can you rebase this against current rawhide?

Also, perhaps we should use a post release versioning here: 
https://fedoraproject.org/wiki/Packaging:Naming?rd=Packaging:NamingGuidelines#Post-Release_packages

Comment 2 Jan Kurik 2016-07-26 04:21:06 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 25 development cycle.
Changing version to '25'.

Comment 3 Lumír Balhar 2016-07-26 07:16 UTC
Created attachment 1184080 [details]
Rebased patch

Hello.

Rebased patch attached. Which scheme of post-release tagging do you prefer? In current specfile I used simple ".a" tag in the release as mentioned in linked guideline. Result is: python-txzmq-0.7.4-5.a.fc24.src.rpm

If this is ok for you, please push this changes.

Comment 4 Kevin Fenzi 2016-07-28 15:34:06 UTC
Well, this is a git snapshot right? not an alpha release?

so, instead of .a how about '.gitWHATEVERHASHIS' ?

ie, python-txzmq-0.7.4-5.git772df64

Comment 5 Lumír Balhar 2016-07-30 18:50 UTC
Created attachment 1185833 [details]
Fixed issue in release number

Hello.

Yes, you are right. I'm providing new version of patch with fixed release.

Is patch ok now?

Koji: http://koji.fedoraproject.org/koji/taskinfo?taskID=15077974

Comment 6 Kevin Fenzi 2016-07-30 20:19:40 UTC
Thanks, applied and built in rawhide. Should I do f25 too?

Comment 7 Lumír Balhar 2016-08-01 07:07:58 UTC
Thank you. Yes, please build it for F25 too. F25 and Rawhide are now separated.

Comment 8 Lumír Balhar 2016-08-04 15:37 UTC
Created attachment 1187570 [details]
Fixing changelog

Hello Ralph.

I've found bug in last changelog entry. I'm providing a small patch to fix them. Could you please apply this patch and make a build for rawhide and F25 soon? I am working on some packages which has this package as dependency.

Thank you very much.
Lumir

Comment 9 Lumír Balhar 2016-08-04 15:41:48 UTC
I am sorry for bad salutation in previous comment Kevin.

Comment 10 Kevin Fenzi 2016-08-08 14:21:34 UTC
Done. No problem on the salutation... ;) 

I fixed the changelog entry on rawhide, but not sure it's worth a new build...

Comment 11 Lumír Balhar 2016-08-08 20:45:32 UTC
Hello Kevin.

I still cannot find the newest build 0.7.4-5. In this page [0] there is previous version 0.7.4-4 in rawhide and F25 built Tue 19 Jul 2016.

[0] https://apps.fedoraproject.org/packages/python-txzmq/overview/

Is mentioned page only out of sync?

Thank you.

Comment 12 Kevin Fenzi 2016-08-08 21:13:38 UTC
Weird. I could have sworn I built it, but it seems I didn't fire off a build somehow. ;( 

Now done: 

https://koji.fedoraproject.org/koji/taskinfo?taskID=15178941

it should appear in tomorrow's rawhide. 

Sorry for the hassles...

Comment 13 Lumír Balhar 2016-08-09 06:32:56 UTC
Thank you very much. Could you please build it also for F25?

Comment 14 Fedora Update System 2016-08-09 14:37:32 UTC
python-txzmq-0.7.4-5.git772df64.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-d23de84155

Comment 15 Fedora Update System 2016-08-10 04:57:28 UTC
python-txzmq-0.7.4-5.git772df64.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-d23de84155

Comment 16 Fedora Update System 2016-08-27 10:45:07 UTC
python-txzmq-0.7.4-5.git772df64.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.