Bug 135907 - hal puts unfriendly names on found devices
hal puts unfriendly names on found devices
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
3
i686 Linux
medium Severity low
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-15 14:49 EDT by Henning Norén
Modified: 2013-03-05 22:41 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-15 18:24:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Henning Norén 2004-10-15 14:49:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041012
Firefox/0.10.1

Description of problem:
When upgrading to hal-0.4.0-2 all the devices formerly named
idedisk[x] changed name to a strange string of characters and integers
(for example "5ed3dc74-bdfa-4463-8a4d-036d7e5263cf").

Reverting back to hal-0.2.98.cvs20040929-3 fixes the problem.



Version-Release number of selected component (if applicable):
hal-0.4.0-2

How reproducible:
Always

Steps to Reproduce:
1. install hal-0.4.0-2
2. change directory to /media 
3. Read the names of the directories there
    

Actual Results:  found devices is having very unfriendly names.

Expected Results:  Found devices should be named as before ("idedisk",
"idedisk1", etc.).

Additional info:
Comment 1 David Zeuthen 2004-10-15 18:24:41 EDT
Hi, yeah, that change was sort of intentional because it would ensure
stable mount points (e.g. the mount point would be the same every time
the storage device / disk was inserted). 

But someone managed to convince me the UUID names was not friendly
enough partly because it is still shown in the UI. We will, however,
use the file system label if it meets certain criteria (it must exist,
it must be ASCII, must not an absolute filesystem path).

This fix is in hal-0.4.0-3.

Note You need to log in before you can comment on or make changes to this bug.