Bug 135917 - Trying to update xorg-x11-font-utils-6.8.1-6 fails with message: requires xorg-x11-base-fonts <= 6.7.99.903-3
Summary: Trying to update xorg-x11-font-utils-6.8.1-6 fails with message: requires xor...
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11   
(Show other bugs)
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-15 19:22 UTC by Xander D Harkness
Modified: 2016-06-07 22:45 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-07 00:05:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Xander D Harkness 2004-10-15 19:22:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041012
Firefox/0.10.1

Description of problem:
I cannot update xorg-x11-font-utils as it seems to have a dependency
for a base-fonts version that is older than itself.  

If I recompile the SRPM then it generates the correct version of
base-fonts but depends upon a different version

Version-Release number of selected component (if applicable):
xorg-x11-font-utils-6.8.1-6 and xorg-x11-base-fonts-6.7.0-6

How reproducible:
Always

Steps to Reproduce:
1.Install FC3 and try to upgrade xorg-x11-font-utils
2. Up2date -u xorg-x11-font-utils 
3. up2date refuses to update font-utils because of an old dependency

    

Actual Results:  Unresolvable chain of dependencies:
xorg-x11-font-utils-6.8.1-6              requires xorg-x11-base-fonts
<= 6.7.99.903-3


Expected Results:  All packages should upgrade to latest versions

Additional info:

Comment 1 Mike A. Harris 2005-03-07 00:05:10 UTC
Fixed since forever now in rawhide..  closing.


Note You need to log in before you can comment on or make changes to this bug.