Bug 135920 - dictd.conf references inexistent dictionaries
Summary: dictd.conf references inexistent dictionaries
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dictd (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-15 19:26 UTC by Marius Andreiana
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-25 16:28:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Marius Andreiana 2004-10-15 19:26:22 UTC
Description of problem:

[root@marte etc]# rpm -V dictd
[root@marte etc]# cat dictd.conf
database web1913   { data "/usr/lib/dict/web1913.dict.dz"
                     index "/usr/lib/dict/web1913.index" }
database wn        { data "/usr/lib/dict/wn.dict.dz"
                     index "/usr/lib/dict/wn.index" }
database gazetteer { data "/usr/lib/dict/gazetteer.dict.dz"
                     index "/usr/lib/dict/gazetteer.index" }
database jargon    { data "/usr/lib/dict/jargon.dict.dz"
                     index "/usr/lib/dict/jargon.index" }
database foldoc    { data "/usr/lib/dict/foldoc.dict.dz"
                     index "/usr/lib/dict/foldoc.index" }
database elements  { data "/usr/lib/dict/elements.dict.dz"
                     index "/usr/lib/dict/elements.index" }
database easton    { data "/usr/lib/dict/easton.dict.dz"
                     index "/usr/lib/dict/easton.index" }
database hitchcock { data "/usr/lib/dict/hitchcock.dict.dz"
                     index "/usr/lib/dict/hitchcock.index" }
[root@marte etc]# rpm -qf dictd.conf
dictd-1.9.7-4

The dictionaries don't exist (are they included in fedora? if yes,
dictd is missing a dependency).
Because of these dictd fails to start:

# service dictd restart
Shutting down dictd:                                       [FAILED]
Starting dictd: :E: /usr/lib/dict/web1913.index is not readable (index
file)
:E: /usr/lib/dict/web1913.dict.dz is not readable (data file)
:E: /usr/lib/dict/wn.index is not readable (index file)
:E: /usr/lib/dict/wn.dict.dz is not readable (data file)
:E: /usr/lib/dict/gazetteer.index is not readable (index file)
:E: /usr/lib/dict/gazetteer.dict.dz is not readable (data file)
:E: /usr/lib/dict/jargon.index is not readable (index file)
:E: /usr/lib/dict/jargon.dict.dz is not readable (data file)
:E: /usr/lib/dict/foldoc.index is not readable (index file)
:E: /usr/lib/dict/foldoc.dict.dz is not readable (data file)
:E: /usr/lib/dict/elements.index is not readable (index file)
:E: /usr/lib/dict/elements.dict.dz is not readable (data file)
:E: /usr/lib/dict/easton.index is not readable (index file)
:E: /usr/lib/dict/easton.dict.dz is not readable (data file)
:E: /usr/lib/dict/hitchcock.index is not readable (index file)
:E: /usr/lib/dict/hitchcock.dict.dz is not readable (data file)
:E: for security, this program will not run as root.
:E: if started as root, this program will change to "dictd" or "nobody".
:E: currently running as user 99/nobody, group 99/nobody
:E: config and db files must be readable by that user
dictd (sanity): :E: terminating due to errors
(sanity) :E: terminating due to errors
                                                           [FAILED]

I have dictd-dictionaries rpm which has dictd.conf too, referencing
it's dictionaries in /usr/share/dict
 rpm -qi dictd-dictionaries
Name        : dictd-dictionaries           Relocations: (not relocatable)
Version     : 0.1.0                             Vendor: (none)
Release     : 9                             Build Date: Fri 27 Jul
2001 03:03:45 PM EEST
Install Date: Fri 15 Oct 2004 10:20:45 PM EEST      Build Host:
parma.redhat.de
Group       : Applications/Databases        Source RPM:
dictd-dictionaries-0.1.0-9.src.rpm
Size        : 47522951                         License: see packages
for copyright
Signature   : (none)
Packager    : enrico.scholz@informatik.tu-chemnitz.de
URL         : ftp://ftp.dict.org/pub/dict/pre
Summary     : Dictionaries for DICT

I think it's correct for dictd to have empty dictd.conf, and
dictionaries rpms should add to it.

Comment 1 Karsten Hopp 2005-01-25 16:28:58 UTC
I've removed the config file from dictd-1.9.7-5 and added some lines
to the init-script to write out a somewhat useful message.


Note You need to log in before you can comment on or make changes to this bug.