Bug 1359220 - Crash while reloading previously invalid but now valid DNS zone
Summary: Crash while reloading previously invalid but now valid DNS zone
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: bind-dyndb-ldap
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Pavel Picka
QA Contact: Kaleem
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-22 14:19 UTC by Martin Bašti
Modified: 2016-11-04 04:51 UTC (History)
3 users (show)

Fixed In Version: bind-dyndb-ldap-10.0-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 04:51:16 UTC
Target Upstream Version:


Attachments (Terms of Use)
evidence (3.63 KB, text/plain)
2016-09-06 11:02 UTC, Pavel Picka
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2375 0 normal SHIPPED_LIVE bind-dyndb-ldap bug fix and enhancement update 2016-11-03 13:51:48 UTC

Description Martin Bašti 2016-07-22 14:19:07 UTC
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/bind-dyndb-ldap/ticket/166

= Problem =
Coredump
{{{
(gdb) bt
#0  0x00007f53e6c296f5 in __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:54
#1  0x00007f53e6c2b2fa in __GI_abort () at abort.c:89
#2  0x000055c048a4c2b8 in assertion_failed (file=<optimized out>, line=<optimized out>, type=<optimized out>, cond=<optimized out>) at ./main.c:232
#3  0x00007f53e9b2fc4a in isc_assertion_failed (file=file@entry=0x7f53e2683dbb "zone_register.c", line=line@entry=553, type=type@entry=isc_assertiontype_require,
    cond=cond@entry=0x7f53e26841b0 "set != ((void *)0) && *set == ((void *)0)") at assertions.c:58
#4  0x00007f53e267a687 in zr_get_zone_settings (zr=<optimized out>, name=0x7f53e0037908, set=set@entry=0x7f53e4ef9c98) at zone_register.c:553
#5  0x00007f53e266c32d in update_record (task=<optimized out>, event=<optimized out>) at ldap_helper.c:3879
#6  0x00007f53e9b5290c in dispatch (manager=0x7f53ea57a010) at task.c:1128
#7  run (uap=0x7f53ea57a010) at task.c:1300
#8  0x00007f53e7c7e5ca in start_thread (arg=0x7f53e4efa700) at pthread_create.c:333
#9  0x00007f53e6cf7ead in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109
}}}

In frame 4, variable set is not empty
{{{
#4  0x00007f53e267a687 in zr_get_zone_settings (zr=<optimized out>, name=0x7f53e0037908, set=set@entry=0x7f53e4ef9c98) at zone_register.c:553
(gdb) p	set
$5 = (settings_set_t **) 0x7f53e4ef9c98
(gdb) p	*set
$6 = (settings_set_t *) 0x7f53ea57a720
}}}

== Steps to Reproduce ==
* run IPA CI DNSSEC test, I'm not able to provide minimal reproducer

= Environment =
* Plugin version:
bind-dyndb-ldap-10.0-1.fc24.x86_64

* Version of ​BIND:
bind-pkcs11-9.10.4-1.P1.fc24.x86_64

* Distribution and version (i.e. including updates):
F24 cloud

* Architecture:
x86_64

* Do you use bind-dyndb-ldap as part of ​FreeIPA installation? If you answered no: IPA

Comment 1 Petr Spacek 2016-07-25 13:45:04 UTC
This used to work in previous versions.

Comment 5 Pavel Picka 2016-09-06 11:02:01 UTC
Created attachment 1198172 [details]
evidence

Verified
10.0-4.el7.x86_64

Comment 7 errata-xmlrpc 2016-11-04 04:51:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2375.html


Note You need to log in before you can comment on or make changes to this bug.