Bug 135924 - Latest nfs-utils update killed speed in stat()
Latest nfs-utils update killed speed in stat()
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
2
All Linux
medium Severity high
: ---
: ---
Assigned To: Steve Dickson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-15 15:34 EDT by Kyrre Ness Sjøbæk
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-18 11:10:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kyrre Ness Sjøbæk 2004-10-15 15:34:32 EDT
Description of problem:
At thursday morning, nfs suddenly became *very* slow. So slow that
loging in to the boxes took 3 minutes instead of 5 secounds - this
problem has been windows-only so far (luckily i don't administer thos
e boxes).

After some digging, if found that the problem probably was do to slow
responce from stat() - ls (which is an alias to ls --colours) tok 10
secounds in /home, while /bin/ls tok 0.01 secound.

The machines mount their /home over version 2 nfs from a debian box, 

My out-of-date laptop do not have any problems, neither did the boxes
have before the upgrade.

It seems like transfer rate is okay, but opening/closing a file takes
_a while_.

Version-Release number of selected component (if applicable):
nfs-utils 1.06-22.i386

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Kyrre Ness Sjøbæk 2004-10-15 15:36:13 EDT
BTW how do i rollback (ie. where do i find a functional RPM? CD's?)
and prevent yum from re-installing the faulty RPM? i use "nightly yum
update". Guess i shouldn't...
Comment 2 Steve Dickson 2004-10-15 17:57:17 EDT
Would it be possible to get a ethereal trace
and the output of nfsstat -rc?
Comment 3 Kyrre Ness Sjøbæk 2004-10-16 14:00:37 EDT
sure, but i have to downgrade most of the boxes asap.

How do i isolate the output to NFS only?
Comment 4 Steve Dickson 2004-10-16 20:27:17 EDT
Try the capture string of "port 2049"
Comment 5 Kyrre Ness Sjøbæk 2004-10-18 10:57:50 EDT
Forget it. My mistake.

The problem was not NFS, it was LDAP. Which matches with the libuser
libary was just updated.

Sorry!

Note You need to log in before you can comment on or make changes to this bug.