Bug 1359267 - multisite: 400 error with certain complete multipart upload requests
Summary: multisite: 400 error with certain complete multipart upload requests
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 2.0
Assignee: Matt Benjamin (redhat)
QA Contact: rakesh
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-22 16:07 UTC by Orit Wasserman
Modified: 2017-07-30 15:48 UTC (History)
10 users (show)

Fixed In Version: RHEL: ceph-10.2.2-27.el7cp Ubuntu: ceph_10.2.2-21redhat1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:44:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 16712 None None None 2016-07-22 16:07:56 UTC
Red Hat Product Errata RHBA-2016:1755 normal SHIPPED_LIVE Red Hat Ceph Storage 2.0 bug fix and enhancement update 2016-08-23 23:23:52 UTC

Description Orit Wasserman 2016-07-22 16:07:57 UTC
Description of problem:
400 error when trying to access complete multipart upload object

Version-Release number of selected component (if applicable):


How reproducible:
Upload an object in one zone, try to access it on another

Steps to Reproduce:
1. configure multisite environment 
2. create a bucket
3. upload a multipart object in one zone
4. access the object from another zone

Actual results:
400 error

Expected results:
200 OK

Additional info:

Comment 2 Orit Wasserman 2016-07-22 16:08:42 UTC
upstream fix: https://github.com/ceph/ceph/pull/10397

Comment 3 Yehuda Sadeh 2016-07-22 16:59:44 UTC
The issue is not when accessing a complete object, but can happen when trying to complete a multipart upload.

Comment 4 Orit Wasserman 2016-07-22 17:05:33 UTC
(In reply to Yehuda Sadeh from comment #3)
> The issue is not when accessing a complete object, but can happen when
> trying to complete a multipart upload.

correct.

Comment 8 errata-xmlrpc 2016-08-23 19:44:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1755.html


Note You need to log in before you can comment on or make changes to this bug.