Bug 135927 - far from bugs free
far from bugs free
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xfsprogs (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-15 15:47 EDT by acount closed by user
Modified: 2013-07-02 22:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-08 19:37:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description acount closed by user 2004-10-15 15:47:47 EDT
the rawhide version of 2.6.13 (03 May 2004) is far from to be the
latest _stable_ version. 

2.6.25 (08 October 2004) version drops a lot of bugs.

-thanks-
Comment 1 Andrew Farris 2004-10-18 16:08:05 EDT
If you're serious about getting this component updated please bring a
list of the bugs or specifically point to _some_ of them that would
warrant a big change in versions like that.  FC3 release is coming
quickly that sounds like a change that will not happen without good
reason.
Comment 2 acount closed by user 2004-10-18 21:09:14 EDT
this bug is about _devel_ aka rawhide not FC3 !! anyway, here they go:

xfsprogs-2.6.25 (08 October 2004)
        - Fix build with really old glibc versions.

xfsprogs-2.6.24 (29 September 2004)
        - Allow 'e' suffix in size arguments to mkfs.
        - Update mkfs man page description of maximum allocation
          group size.
        - Update mkfs and xfs_db man pages to use consistent,
          standard notations.
        - Sync up user/kernel source in libxfs and headers.

xfsprogs-2.6.23 (17 September 2004)
        - Fix xfs_io pread/pwrite -b option, when used more than
          once we would use the largest of the previous values,
          instead of the (possibly smaller) value specified.
        - Add recursive modes to lsattr/chattr xfs_io commands.
        - Make xfs_io run any given command line commands (-c)
          on all files specified, not just the first.

xfsprogs-2.6.22 (10 September 2004)
        - Update xfs_io to get a clean compile on IRIX with the
          MIPSPro compilers.
        - Add documentation about additional XFS inode flags.
        - Add xfs_io write options to include fsync/fdatasync
          in the timing results it displays.
        - Add xfs_fsop_counts output to the xfs_io statfs data,
          which also shows free realtime space, etc.
        - Add knowledge of additional inode flags for nosymlinks
          and project ID inheritance.

xfsprogs-2.6.21 (09 August 2004)
        - Support realtime bit inheritance on directories.
        - Fix xfs_io build with unusual (old) glibc versions.
        - Fix tools to not issue the BLKFLSBUF ioctl to ramdisk
          devices.  Thanks to Bo Yang for this fix.

xfsprogs-2.6.20 (28 July 2004)
        - Fix a segfault on xfs_io open error path for non-XFS
          files.  Thanks to Steinar H. Gunderson for this fix.

xfsprogs-2.6.19 (16 July 2004)
        - Fix two byte count size wraps in xfs_copy.
        - Minor man page fixes from Eric Raymond.

xfsprogs-2.6.18 (23 June 2004)
        - Fix libhandle from possibly returning an invalid
          handle length on systems where size_t is 64 bits.
        - Minor autoconf fixups to get rpm test working on
          all platforms again.
        - Minor man page updates fixing minus/hyphen usage.

xfsprogs-2.6.17 (23 June 2004)
        - Fix use of isset macro, getting realtime devices to
          function correctly in xfs_db and xfs_repair.
        - Fix initialisation of realtime devices in libxfs.

xfsprogs-2.6.16 (17 June 2004)
        - Add sendfile command into xfs_io(8) to exercise that
          functionality.
        - Remove maxtrres program that was used in the build
          to generate a header for mkfs' consumption.
        - This allows cross-compiles to be greatly simplified.
        - Portability tweaks for building on other platforms.
        - Fix obscure bug in log size lower boundary checks for
          auto-sized logs when stripe alignment is in effect;
          the enforced lower bound could have been set too low.

xfsprogs-2.6.15 (09 June 2004)
        - Make xfs_check test for a dirty log before proceeding to
          check the filesystem.
        - Fix couple of minor bugs in xfs_io (readonly handling on
          writes, off-by-one error in open file error reporting).

xfsprogs-2.6.14 (13 May 2004)
        - Allow logprint to copy a log to a file (-C) and to dump
          a log from beginning to end showing ondisk log record (-d).
        - Fix logprint handling of -f option - shouldn't be doing
          the UUID check in that case, since we don't have the SB.
        - Remove MD device superblock "clean" check, following Neil
          Brown's advice.
        - Small Debian packaging tweak to say xfsprogs has an fsck.


if you should update the package is up to you.

-thanks-
Comment 3 acount closed by user 2004-11-08 19:37:24 EST
nobody cared, maybe the next century. Closing...

Note You need to log in before you can comment on or make changes to this bug.