Bug 135928 - kdeaddons and other pre test 3 packages have yum install issues.
Summary: kdeaddons and other pre test 3 packages have yum install issues.
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kdeaddons
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-15 19:50 UTC by Stephen John Smoogen
Modified: 2007-11-30 22:10 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2004-10-18 08:00:38 UTC


Attachments (Terms of Use)

Description Stephen John Smoogen 2004-10-15 19:50:19 UTC
Description of problem:

Packages are not installable via yum.

They seem to require libraries that yum is not able to find
explicitely. Package needs to have a formal requires.


Version-Release number of selected component (if applicable):
 kdeaddons-3.3.0-2.src.rpm

How reproducible:
100%

Steps to Reproduce:
1. yum install kdeaddons

Comment 1 Bill Nottingham 2004-10-15 20:45:29 UTC
What's the specific dependency?

Comment 2 Ngo Than 2004-10-16 07:56:37 UTC
i use yum to update my local machine everyday, it works for me. I did
not see this problem. It's helpful if you could give more details.
Thanks

Comment 3 Stephen John Smoogen 2004-10-16 14:42:53 UTC
Bug can be closed. It seems that yum repository changes since Sunday
have fixed the problem. On Monday what I got was:

[root@bake_neko ~]# yum install kdeaddons
Setting up Install Process
Setting up Repo:  development
repomd.xml                100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 952 kB    00:16
MD Read   : ################################################## 3433/3433
developmen: ################################################## 3433/3433
Resolving Dependencies
kdeaddons-3.3.0-2.i386.rp 100% |=========================|  65 kB    00:01
Processing Dependency: libnoatun.so.1 for package: kdeaddons
Processing Dependency: libkabinterfaces.so.1 for package: kdeaddons
Processing Dependency: libartsmodulessynth.so.0 for package: kdeaddons
Processing Dependency: libartsbuilder.so.0 for package: kdeaddons
Processing Dependency: libnoatuntags.so.1 for package: kdeaddons
Processing Dependency: libartsmodulescommon.so.0 for package: kdeaddons
Processing Dependency: libnoatuncontrols.so.1 for package: kdeaddons
Processing Dependency: libartsmoduleseffects.so.0 for package: kdeaddons
Processing Dependency: libnoatunarts.so for package: kdeaddons
Processing Dependency: libartsmodules.so.0 for package: kdeaddons
Processing Dependency: libartsgui.so.0 for package: kdeaddons
Processing Dependency: libartsmidi_idl.so.0 for package: kdeaddons
Processing Dependency: libartsmodulesmixers.so.0 for package: kdeaddons
Processing Dependency: libartsgui_kde.so.0 for package: kdeaddons
Processing Dependency: libartsgui_idl.so.0 for package: kdeaddons

and yum could not figure out what provided that. I just tried to
replicate it and yum found kdemultimedia and kdepim. I do think that
kdeaddons does need an explicite requires for those 2 packages.

Sorry for the confusion.
Stephen

Comment 4 Ngo Than 2004-10-18 08:00:38 UTC
it's fixed in rawhide. thanks for your testing


Note You need to log in before you can comment on or make changes to this bug.