This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 135932 - NVIDIA OpenGL module won't load automatically when X is started
NVIDIA OpenGL module won't load automatically when X is started
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: udev (Show other bugs)
4.0
All Linux
high Severity high
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-15 15:53 EDT by John A. Hull
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-29 08:57:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John A. Hull 2004-10-15 15:53:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914
Firefox/0.10

Description of problem:
With FC3 and RHEL 4, after compiling the nvidia module for a specified
kernel and putting an entry for char-major-195 into modprobe.conf, the
nvidia module is not automatically loaded when X is started. Using any
of the following in /etc/modprobe.conf does not work: "alias
char-major-195*", "alias char-major-195-*", "alias char-major-195", or
"alias char-major-195-0". 

Running "modprobe nvidia" and then starting X works fine. 

This is not a problem on FC2. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Compile the nvidia module for a kernel
2. add a char-major-195 alias into modprobe.conf for the nvidia module
3. Reboot into runlevel 5. Module does not get loaded. 
    

Additional info:
Comment 1 Mike A. Harris 2004-10-16 03:45:09 EDT
Thanks for the report.  For users who are experiencing problems
installing, configuring, or using the unsupported 3rd party
proprietary "nvidia" video driver, Nvidia provides indirect
customer support via an online web based support forum.  Nvidia
monitors these web forums for commonly reported problems and
passes them on to Nvidia engineers for investigation.  Once
they've isolated a particular problem, it is often fixed in
a future video driver update.

The NVNews Nvidia Linux driver forum is located at:

    http://www.nvnews.net/vbulletin/forumdisplay.php?s=&forumid=14

Once you have reported this issue in the Nvidia web forums,
others who may have experienced the particular problem may
be able to assist.  If there is a real bug occuring, Nvidia
will be able to determine this, and will likely resolve the
issue in a future driver update for the operating system
releases that they officially support.

While Red Hat does not support the proprietary nvidia driver,
users requiring technical support may also find the various
X.Org, XFree86, and Red Hat mailing lists helpful in finding
assistance:

X.Org mailing lists:
    http://www.freedesktop.org/XOrg/XorgMailingLists

XFree86 mailing lists:
    http://www.xfree86.org/sos/lists.html

Red Hat mailing lists:
    https://listman.redhat.com/mailman/listinfo

Setting status to "NOTABUG" (unsupported).
Comment 2 John A. Hull 2004-10-16 08:46:14 EDT
Mike,

I know Red Hat's party line on the NVIDIA driver, and that's fine. The
reason I filed this in Red Hat's bugzilla is that it appears to me
this might be an OS bug. The same NVIDIA driver loads fine with
char-major-195 in FC2 and other distros, but not FC3/RHEL 4. This
leads me to believe that you guys changed something in the OS that
causes a char-major-195 device to not get automatically loaded. Can
you say for sure this isn't an OS bug? With Red Hat's push into the
desktop, too many people will be using NVIDIA OpenGL drivers to just
blow this off. 
Comment 3 Uwe Beck 2004-10-16 17:46:03 EDT
RHEL4_BETA1 and also last FC3beta use udev. You can find some
informations and temporary fix on
http://people.redhat.com/harald/udev.html
 -> Current Problems on Fedora -> Nvidia
I think this is an OS bug at this time which comes from udev.
Comment 4 Mike A. Harris 2004-10-17 05:41:21 EDT
The device handling is different in FC3 as udev is now used, which
I hadn't previously considered when initially reviewing the report.
It now appears that this is the likely cause of the problem.

Thanks for the additional information, I've reopened the report
and am reassigning to the "udev" component for review.


Comment 5 Harald Hoyer 2004-10-18 11:34:52 EDT

*** This bug has been marked as a duplicate of 130746 ***
Comment 6 Amit Bhutani 2004-11-23 14:20:14 EST
Reopening this issue since the dup of this (BZ130746) has become
unweildy and does not properly reflect the severity of the issue. We
want to make it clear that this particular issue is an RC Blocker for
Dell. Raising the severity accordingly. I am going to remove 130746
from  my RC Blocker list and add this one (135932). 
Comment 7 Arjan van de Ven 2004-11-24 04:16:48 EST
This really needs to be fixed by nvidia.
*ALL* other X drivers load their respective (DRM) kernel modules from
inside the X driver. NVidia should do that too.
Comment 8 Mike A. Harris 2004-11-24 08:06:18 EST
Nvidia either needs to load their kernel module from inside their
video driver, like all other video drivers do, as mentioned by
Arjan above, or in the mean time, they need to write an initscript
or some other mechanism to work around this limitation in their
driver.

This is not to my knowledge a udev bug at all, so I'm not sure what
Red Hat is expected to do about this problem.  It is a driver
limitation.

It might be a good idea however for Dell, Red Hat, and Nvidia to
discuss this specific problem on a higher level, to make sure
everyone knows what the fix is, who needs to do it, and to
make sure it is done correctly and in time for whatever
deadlines.  Right now it just seems to be a hot potato filled
with a lot of misunderstanding.
Comment 10 Susan Denham 2004-12-03 09:10:43 EST
Dell team:  in Amit's latest 01 Dec RHEL4ZILLA list, he lists this as
an RC blocker.  We agreed that although unpleasant, the problem is a
limitation with the Nvidia driver rather than a udev bug.   As a
result, this bug is NOT on RH's RC blocker list.
Comment 11 Susan Denham 2004-12-03 09:15:00 EST
Oops:  my bad.  Amit REMOVES this as an RC blocker, and I've done so
as well.

Note You need to log in before you can comment on or make changes to this bug.