Bug 1359370 - glfs: fix glfs_set_volfile_server doc
Summary: glfs: fix glfs_set_volfile_server doc
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: libgfapi
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Prasanna Kumar Kalever
QA Contact: Sudhir D
URL:
Whiteboard:
Depends On:
Blocks: 1376677
TreeView+ depends on / blocked
 
Reported: 2016-07-23 09:29 UTC by Prasanna Kumar Kalever
Modified: 2017-03-27 18:21 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.9.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1376677 (view as bug list)
Environment:
Last Closed: 2017-03-27 18:21:04 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Prasanna Kumar Kalever 2016-07-23 09:29:33 UTC
Description of problem:
Gluster supports volume file fetching over transports tcp and unix only.
The current glfs_set_volfile_server() doc misleads by mentioning rdma,
which should be removed

More about the discussion around @
http://www.gluster.org/pipermail/gluster-devel/2016-July/050114.html


Version-Release number of selected component (if applicable):
mainline

Comment 1 Vijay Bellur 2016-07-23 09:29:58 UTC
REVIEW: http://review.gluster.org/14995 (glfs: fix glfs_set_volfile_server doc) posted (#1) for review on master by Prasanna Kumar Kalever (pkalever@redhat.com)

Comment 2 Vijay Bellur 2016-07-25 07:17:19 UTC
REVIEW: http://review.gluster.org/14995 (glfs: fix glfs_set_volfile_server doc) posted (#2) for review on master by Prasanna Kumar Kalever (pkalever@redhat.com)

Comment 3 Vijay Bellur 2016-07-27 09:06:57 UTC
REVIEW: http://review.gluster.org/14995 (gfapi: fix glfs_set_volfile_server doc) posted (#3) for review on master by Prasanna Kumar Kalever (pkalever@redhat.com)

Comment 4 Vijay Bellur 2016-08-02 17:06:26 UTC
COMMIT: http://review.gluster.org/14995 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit d83105ac8537e8531b9c2210a501734b587ed8d8
Author: Prasanna Kumar Kalever <prasanna.kalever@redhat.com>
Date:   Sat Jul 23 14:33:17 2016 +0530

    gfapi: fix glfs_set_volfile_server doc
    
    Gluster supports volume file fetching over transports tcp and unix only.
    The current glfs_set_volfile_server() doc misleads by mentioning rdma,
    which is removed by this patch.
    
    More about the discussion around @
    http://www.gluster.org/pipermail/gluster-devel/2016-July/050114.html
    
    Change-Id: I08cfe262fb9a82cb341f6adbe93594c8e628b7fe
    BUG: 1359370
    Signed-off-by: Prasanna Kumar Kalever <prasanna.kalever@redhat.com>
    Reviewed-on: http://review.gluster.org/14995
    Tested-by: Prasanna Kumar Kalever <pkalever@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 5 Shyamsundar 2017-03-27 18:21:04 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.0, please open a new bug report.

glusterfs-3.9.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2016-November/029281.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.