Bug 1359406 - [RGW:NFS]:- Can't create object of size more than 256k from nfs mount point
Summary: [RGW:NFS]:- Can't create object of size more than 256k from nfs mount point
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 2.0
Hardware: x86_64
OS: Unspecified
unspecified
high
Target Milestone: rc
: 2.0
Assignee: Matt Benjamin (redhat)
QA Contact: shylesh
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-23 19:50 UTC by shylesh
Modified: 2017-07-30 15:44 UTC (History)
12 users (show)

Fixed In Version: RHEL: ceph-10.2.2-36.el7cp Ubuntu: ceph_10.2.2-28redhat1xenial
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:45:03 UTC
Target Upstream Version:
kurs: needinfo-


Attachments (Terms of Use)
ganesha logs for this particular write op (40.17 KB, text/plain)
2016-07-23 19:50 UTC, shylesh
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1755 normal SHIPPED_LIVE Red Hat Ceph Storage 2.0 bug fix and enhancement update 2016-08-23 23:23:52 UTC

Description shylesh 2016-07-23 19:50:52 UTC
Created attachment 1183148 [details]
ganesha logs for this particular write op

Description of problem:
Trying to create an object of size greater than 256k is not possible from nfs mount point

Version-Release number of selected component (if applicable):

ceph-radosgw-10.2.2-26.el7cp.x86_64
nfs-ganesha-rgw-2.3.2-2.el7cp.x86_64
nfs-ganesha-2.3.2-2.el7cp.x86_64

How reproducible:

always

Steps to Reproduce:
1. create a nfs-rgw setup with ganesh and mount .
2. try to create an object of size more than 256k 

dd if=/dev/urandom of=file bs=1M count=1
dd: error writing ‘file’: Input/output error
1+0 records in
0+0 records out
0 bytes (0 B) copied, 1.78552 s, 0.0 kB/s

-rw-rw-rw-. 1 root root 262144 Jul 23 19:27 file

from the output we can observer that only 256k is written.

 Attaching the logs

Comment 12 shylesh 2016-08-10 10:16:26 UTC
Verified on librgw2-10.2.2-38.el7cp.x86_64

Comment 15 errata-xmlrpc 2016-08-23 19:45:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1755.html


Note You need to log in before you can comment on or make changes to this bug.