Bug 135944 - anacond's Edit Drive Order Dialog
anacond's Edit Drive Order Dialog
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-15 16:32 EDT by Jack Neely
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-13 12:53:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jack Neely 2004-10-15 16:32:59 EDT
Description of problem:

In the Advanced Boot Loader screen bring up the dialog box to edit the
drive order anaconda thinks your BIOS sees drives in.

You can select an empty row below the last drive and click on the
buttons to move it.  This produces the following traceback:

File
"/usr/src/build/452771-i386/install//usr/lib/anaconda/iw/driveorderwidget.py",
line 102, in arrowClicked
   drive = model.get_value(iter, 0)[5:]
TypeError: unsubscriptable object

This was tested on a machine with one hard drive.  I've noticed in
RHEL 3 U2 issues with actuall not being able to change the order of
drives in the dialog box but I haven't tested in RHEL4b1 as the above was.
Comment 1 Jeremy Katz 2004-10-15 16:55:23 EDT
Fixed in CVS
Comment 2 Jay Turner 2005-01-13 12:53:39 EST
Closing out.  Please reopen if the problem is still present with recent code.

Note You need to log in before you can comment on or make changes to this bug.