Bug 135958 - chg-manual shell script has syntax error
Summary: chg-manual shell script has syntax error
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: amanda   
(Show other bugs)
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jay Fenlason
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 156320
TreeView+ depends on / blocked
 
Reported: 2004-10-15 21:30 UTC by Robert Wehner
Modified: 2015-01-08 00:08 UTC (History)
2 users (show)

Fixed In Version: RHBA-2005-533
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-28 17:35:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:533 qe-ready SHIPPED_LIVE amanda bug fix update 2005-09-28 04:00:00 UTC

Description Robert Wehner 2004-10-15 21:30:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040707 Firefox/0.9.2

Description of problem:
amcheck produces and error when the backup config has the manual tape
changer script enabled.:
amcheck-server: could not get changer info: badly formed result from
changer: "/usr/lib/amanda/chg-manual: line 33: -E: command not found"

Line 33 is:
EGREP=grep -E

It this is quoted, amcheck will work:
EGREP="grep -E"

Version-Release number of selected component (if applicable):
amanda-server-2.4.4p1-0.3E

How reproducible:
Always

Steps to Reproduce:
1. Install amanda-server and amanda RPMS
2. Configure Amanda normally (disklist, tapelist, amanda.conf). Be
sure that you have the following in your amanda.conf:
tpchanger "chg-manual"
changerfile "/var/lib/amanda/<conf_name>/changer"
/var/lib/amanda/<conf_name>/changer should be the alternative "email"
request() function as written in /usr/lib/amanda/chg-manual (commented
out).
3. run amcheck -m <conf_name> as amanda
    

Actual Results:  Amanda emails out a report. The amanda-server section
of the report will show this error:
amcheck-server: could not get changer info: badly formed result from
changer: "/usr/lib/amanda/chg-manual: line 33: -E: command not found"


Expected Results:  /usr/lib/amanda/chg-manual should not produce a
command not found error causing amcheck to report an Amanda problem.
(probably amdump will also fail due to this, though I have not tried
that.)

Additional info:

Comment 1 Jay Fenlason 2005-05-02 17:15:46 UTC
I've put test rpms of amanda*-2.4.4p1-0.3E.1.{src,i386}.rpm up on 
http://people.redhat.com/fenlason/.amanda/  Please try them out and report 
whether they fix this problem. 

Comment 6 Robert Wehner 2005-08-04 20:16:22 UTC
The new RPMs work for me. Thanks and sorry for the dealy in testing these out.

Comment 7 Red Hat Bugzilla 2005-09-28 17:35:39 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-533.html



Note You need to log in before you can comment on or make changes to this bug.