Bug 135964 - Hald crashes on startup
Summary: Hald crashes on startup
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: hal   
(Show other bugs)
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-15 22:18 UTC by Martin Braun
Modified: 2013-03-06 03:41 UTC (History)
1 user (show)

Fixed In Version: 0.4.0-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-16 19:10:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
debug messages when starting hald and crash location (73.79 KB, text/plain)
2004-10-15 22:21 UTC, Martin Braun
no flags Details

Description Martin Braun 2004-10-15 22:18:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041012

Description of problem:
After upgrading to today's Rawhide (2004/10/15) I noticed that hald
was not running after a restart (/media was empty). I compiled hald
from sources and was able to reproduce the crash.

Version-Release number of selected component (if applicable):
hal-0.4.0-2

How reproducible:
Always

Steps to Reproduce:
1. start hald (/etc/rc.d/init.d/haldaemon start)
2./etc/rc.d/init.d/haldaemon status
3.
    

Actual Results:  hald is stopped

Expected Results:  hald should be running

Additional info:

starting hald manually (/usr/sbin/hald --verbose=yes --daemon=no)
produces a crash (sgfault)

Comment 1 Martin Braun 2004-10-15 22:21:26 UTC
Created attachment 105309 [details]
debug messages when starting hald and crash location

Comment 2 Martin Braun 2004-10-16 19:10:37 UTC
I just installed hal-0.4.0-3. hald now works for me
(No Crashes, proper fstab entries and directories in /media)


Note You need to log in before you can comment on or make changes to this bug.