Bug 135976 - Latest hal update no longer updates mountpoints or fstab for several of my devices
Latest hal update no longer updates mountpoints or fstab for several of my de...
Status: CLOSED DUPLICATE of bug 133777
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
Depends On:
  Show dependency treegraph
Reported: 2004-10-15 19:52 EDT by Jef Spaleta
Modified: 2013-03-05 22:41 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:06:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
hald --verbose=yes output for usb-storage device insertion (71.10 KB, text/plain)
2004-10-15 19:55 EDT, Jef Spaleta
no flags Details

  None (edit)
Description Jef Spaleta 2004-10-15 19:52:11 EDT
Description of problem:
no longer creates mountpoints or fstab entries for my
floppy nor any of my usb-storage devices.

The udev does create the device listings by hal doesn't seem to be
updating the /media or /etc/fstab

Hal does see my ide cdrw drive.
/dev/hdb                /media/cdrecorder       iso9660,udf
0 0

floppy module is loaded and /dev/fd0 exists but no floppy fstab entry
or mount point. 

Attached is a log from hald --verbose=yes --daemon=no
showing what happens when i attach a usb-storage device.
/dev/sda1 is created but no mountpoint or fstab entry.

-jef"so is the hal cha-cha one step forward two step backs..or two
steps forward and one step back...i shouldn't have quit that ballroom
dance class"spaleta
Comment 1 Jef Spaleta 2004-10-15 19:55:42 EDT
Created attachment 105315 [details]
hald --verbose=yes   output for usb-storage device insertion
Comment 2 David Zeuthen 2004-10-16 00:10:46 EDT
This is caused by running the 2.6.8-1.624 kernel. Downgrading to an
earlier kernel, say .610, will make it work again. Alternatively, an
upgrade hal-0.4.0-3 package will appear in Rawhide tomorrow.

Comment 3 Jef Spaleta 2004-10-16 10:13:46 EDT
Installed hal-0.4.0-3  this morning using 2.6.8-1.624 kernel,
and the problem persists hal isnt creating a floppy drive entry for
me.  I restarted the daemon to make sure. i even rmmod floppy 
modprobe floppy.

Maybe something else is wrong as well....


Comment 4 David Zeuthen 2004-10-16 10:16:39 EDT
That's odd - few questions

 1. Does hal-0.4.0-3 create the floppy drive on an earlier kernel?
 2. Does hal.0.4.0-3 work with USB devices on the .624 kernel?

Comment 5 Jef Spaleta 2004-10-16 15:18:16 EDT
I'll get back and test older kernels as soon as im physically at that
box again....

Comment 6 Jef Spaleta 2004-10-16 17:16:24 EDT
Okay i got a chance to get back to the box....
kernel:  2.6.8-1.610smp
hal: 0.4.0-3
udev: 038-2

I have a floppy device /dev/fd0
I have no floppy mountpoint nor fstab entry.

Problem is I have no idea which version of hal stopped handling the
fd0 entry.

I plugin the usb-storage keydrive and i get an sda1 device and
i get a mountpoint and fstab entry. Hey and i can write too it as
console user, so thats a nice silver lining.

the wife took the digital camera so i cant test the flash card reader
or the camera itself.  

I'll boot back into -624smp and confirm im still seeing the
usb-storage problem.

Comment 7 Jef Spaleta 2004-10-16 17:49:32 EDT
back into -624smp

my usb-storage device DOES work!!!!!!!!

still no floppy fstab entry or mountpoint.

Comment 8 Bob Cochran 2004-10-16 18:15:08 EDT
This issue has been happening to me as well, using the 624 x86_64
kernel (I'm using an AMD Athlon 64 3500+ processor and an MSI K8N Neo2
Platinum motherboard.) With hal-0.4.0-2 and the 624 kernel, my floppy
device would disappear from /etc/fstab and there would be no mount
point in /media for it. This was also true of the 603 and 610 kernels
(again in the x86_64 arch.) Updating to hal 0.4.0-3 had the same
result with the 624 kernel.

Then I hand-coded an entry for /dev/fd0 in fstab, but removed the
'managed' option from the list of options:

auto   noauto,user,exec 0 0

instead of

auto   noauto,user,exec,managed 0 0

And this seemed to work great when I booted into the 610 kernel -- my
fstab entry for /dev/fd0 is preserved. I rebooted into the 624 kernel
and again my fstab entry for fd0 is preserved.

Comment 9 Michal Jaegermann 2004-10-16 19:30:23 EDT
I am running right now kernel 2.6.8-1.610 on x86_64 and hal-0.4.0-3.
Also selinux is turned off.  Entries for floppies are _not_ created.
I can observe that a floppy drive is accessed twice between
runlevel 1 and login prompt on runlevel 3 (it lights up) but
it does not have any further consequences.  Does not matter if
a readable floppy is present in a drive or not.

CD-RW and a USB floppy (I do not have any USB memory stick right now)
are handled in an expected manner.
Comment 10 Rodolfo J. Paiz 2004-10-16 21:02:14 EDT
Running the 610 kernel and hal-0.4.0-3 on FC3-T2, the /media/floppy
directory is created and so is the /etc/fstab entry. Inserting a
floppy in the drive (external USB floppy on IBM Thinkpad T23 2647-5NU)
does not cause the floppy icon to appear on the desktop; that happens
only after I open "Computer" and double-click "External Floppy".

However, when I right-click on the Floppy icon either on the desktop
or in the "Computer" window, the "Format" option does not appear. I am
able to use dd to put install images for FC1 onto the floppy disk and
I am able to browse the files on the floppy. Just no "Format" command. 
Comment 11 victor lorenz 2004-10-17 12:44:17 EDT
Same issue with floppy and my Zip (/dev/hdb4) - no fstab entries.
Reverted to 2.6.8-1.607 (610 doesn't work for me - kernel panic)
problem persists. Problem started appearing with develop't updates of
around Oct. 13
AMD Athlon 2100.
Comment 12 David Zeuthen 2004-10-17 15:47:05 EDT
OK, I think this bug concerns the code I've added from comment 11 in
bug 133777 to detect whether a floppy drive really is present - I'll
debug this tomorrow when I get into the office because I need a
machine with a real floppy drive instead of just a controller. I did
test it on a Dell desktop PC before putting it in Rawhide but perhaps
the checks are a bit too restrictive.

Comment 13 David Zeuthen 2004-10-18 13:26:07 EDT
Closing this as a duplicate of bug 133777 - discussion continues in
that bug.

*** This bug has been marked as a duplicate of 133777 ***
Comment 14 Red Hat Bugzilla 2006-02-21 14:06:20 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.