Bug 135981 - Installer hangs when switching from text to grapical mode.
Installer hangs when switching from text to grapical mode.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-15 23:30 EDT by Gary P. Gottlieb
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-28 09:15:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log file (47.66 KB, text/plain)
2004-11-12 20:04 EST, Gary P. Gottlieb
no flags Details
Xorg log file (59.71 KB, text/plain)
2004-11-12 20:05 EST, Gary P. Gottlieb
no flags Details
anaconda log file (17.65 KB, text/plain)
2004-11-12 20:06 EST, Gary P. Gottlieb
no flags Details
anaconda syslog file (19.72 KB, text/plain)
2004-11-12 20:07 EST, Gary P. Gottlieb
no flags Details
xorg.conf file (3.10 KB, text/plain)
2004-11-15 21:30 EST, Gary P. Gottlieb
no flags Details
kudzu output (183 bytes, text/plain)
2004-11-16 18:24 EST, Gary P. Gottlieb
no flags Details

  None (edit)
Description Gary P. Gottlieb 2004-10-15 23:30:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040922

Description of problem:
When I try to install FC3-Test3 on my Compaq Presario 1500 Notebook,
anaconda hangs when going to graphics mode after discovering hardware.
 This only happens on my Compaq Notebook with an ATI Mobility 7500
graphics card.  The screen turns white after the hardware probe and
the installer hangs.  Tried both DVD and CD install disks.  Works fine
on my other desktops - Gateway w/ ATI 7000 and an AMD Homebrew w/
nVidea 5200.  FC2 installs fine on my Compaq.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Put FC3-Test3 DVD or CD1 in drive.
2.Reboot.
3.Press <enter> at Boot:
    

Actual Results:  Screen turns white and installer hangs.

Expected Results:  "X" comes up then graphical installer runs.

Additional info:

Only happens on Compaq Presario 1500 w/ ATI Mobility 7500.  Fedora
Core 2 (Final Release) works fine.  Please go back to driver that was
used in FC2.  Thanks.
Comment 1 Jeremy Katz 2004-10-17 18:06:24 EDT
Does it work better if you boot with 'linux nofb'?
Comment 2 Gary P. Gottlieb 2004-10-17 19:25:24 EDT
No, I just tried it twice and the results are the same as above. 
Fedora Core 1, Fedora Core 2, and Redhat EL 3 all work fine.  It is
only Fedora  Core 3 - Test 3 that is broken.  I have not tried Fedora
Core 3 - Test 1 or Test 2.
Comment 3 Gary P. Gottlieb 2004-10-18 08:34:18 EDT
Here is some additional information I found out by trial and error 
last night.  This problem only happens when the installer "attempts" 
to switch the graphics screen resolution.  My Compaq notebook is 
currently running Fedora Core 2 at 1400x1050 resolution.  If I enter 
the command "linux resolution=1400x1050" at the boot prompt (Fedora 
Core 3 - Test 3), the installer works in graphical mode (the 
graphical installer screen is really small though).  Likewise if my 
resolution before the install is set to something different, the only 
way I can get the graphical install to work is by issuing the "linux 
resolution=XxY" where X and Y are the current resolution before the 
install.  Like I mentioned before this only happens on FC3-test3 and 
on my Compaq Notebook.  All the rest of my PCs and Linux 
distributions work fine.
Comment 4 Jeremy Katz 2004-10-18 17:30:59 EDT
If you do a text mode install, does X come up fine afterwards?  Can
you attach a /var/log/Xorg.0.log from your running system?
Comment 5 Gary P. Gottlieb 2004-10-18 18:26:17 EDT
I did not let the program run that far.  I would abort the install
before the file system was written to.  With Fedora Core 3 coming out
in  less than two weeks, I do not want to install Test 3 at this time.
 I will install Fedora Core 3 as soon as I can down load it and burn a
DVD.  I will then report to you my findings.  I am afraid that if I do
a complete install of Test 3 and X does not work, I will have to go
back to Fedora Core 2, just to try Fedora Core 3 in a matter of a few
days.  Please keep this bug report open until I get back to you.  I
can always do the proceedure explained in my previous comments (#3) to
complete the install.
Comment 6 Gary P. Gottlieb 2004-11-12 09:32:38 EST
I have recently installed the Fedora Core 3 and the same problem 
occurred.  I have changed the version on this report from "fc3test3" 
to "fc3".  After the problem occurred, I rebooted the computer and 
used the method in Comment #3.  The install ran fine at that point.  
Please advise if you want any attachments or new information.  My 
Fedora Core 3 installation is now up and running perfectly.
Comment 7 Jeremy Katz 2004-11-12 10:46:38 EST
Please provide the /var/log/Xorg.* from your system as well as
/var/log/anaconda*
Comment 8 Gary P. Gottlieb 2004-11-12 20:04:45 EST
Created attachment 106628 [details]
Xorg log file
Comment 9 Gary P. Gottlieb 2004-11-12 20:05:27 EST
Created attachment 106629 [details]
Xorg log file
Comment 10 Gary P. Gottlieb 2004-11-12 20:06:20 EST
Created attachment 106630 [details]
anaconda log file
Comment 11 Gary P. Gottlieb 2004-11-12 20:07:09 EST
Created attachment 106631 [details]
anaconda syslog file
Comment 12 Paul Nasrat 2004-11-15 13:32:31 EST
Can you paste the output of running as root kudzu -p -b ddc and attach
your xorg.conf file please.
Comment 13 Gary P. Gottlieb 2004-11-15 21:30:02 EST
Created attachment 106779 [details]
xorg.conf file
Comment 14 Gary P. Gottlieb 2004-11-15 21:33:55 EST
I tried to run "/etc/sysconfig/kudzu -p -b ddc" logged in as root and
I got "bash: /etc/sysconfig/kudzu: Permission denied" returned.
Comment 15 Paul Nasrat 2004-11-16 16:37:54 EST
/usr/sbin/kudzu 
Comment 16 Paul Nasrat 2004-11-16 16:39:33 EST
Can you try commenting out the line:

	InputDevice    "Synaptics" "AlwaysCore"

in your xorg.conf and see if that makes a difference?
Comment 17 Gary P. Gottlieb 2004-11-16 18:24:42 EST
Created attachment 106853 [details]
kudzu output
Comment 18 Gary P. Gottlieb 2004-11-16 18:29:21 EST
Why would the action in Comment #16 have anything to do with the
display problems during a full installation of FC3?  That is my
touchpad and it works fine.  I can only test a fix to the installer by
trying a new installation.  I would abort the install before it writes
to my file system because FC3 is now configured and running fine.
Comment 19 Yurii Kantonistov 2005-06-25 18:07:47 EDT
Have the same problem with mobo ASUS A8N-E Deluxe and video PCI-E Radeon X700.
Nothing did help with FC3 installer (nofb, lowres, etc., I have tried nearly
everything). Now with FC4 things did not improve either.
I can attach anaconda log if it might help, but please advise me how to 
get it and from where.
In text mode everything works fine. 
P.S. Cannot get XWindows to work in FC3 on this PC.
Comment 20 Jeff 2005-09-11 15:18:59 EDT
I am having the same problem with an ASUS A8N-E board and a Nvidia GeForce 6600
GT video card.

The screen image just goes garbled after seaching for video, mouse, etc.

Any help getting past this would be greatly appricieated.

This is an x86 64 installation.
Comment 21 Jeff 2005-09-12 08:53:14 EDT
Update:

FC4 Install seems to work without a hitch.
Comment 22 Yurii Kantonistov 2005-09-16 17:58:10 EDT
When replaced Radeon with X700 GeForce 6600TGT - no problem, graphical installer
& XOrg/GNOME work perfectly.
Comment 23 Paul Nasrat 2005-11-28 16:54:37 EST
Does FC5 test1 work any better?
Comment 24 John Thacker 2006-04-28 09:15:04 EDT
No response for a while from reporter.  FC3 is now the responsibility 
of Fedora Legacy, and this is not a security bug.  Please report
against FC5 if installation bugs still occur; a lot of work has gone
into anaconda since then.
Comment 25 Yurii Kantonistov 2006-05-01 15:31:43 EDT
I do not have that hardware anymore (Radeon X700).
Combination I have right now: ASUS A8N-SLI + GeForce 6600GT 
works perfectly with both FC4 and FC5.

Note You need to log in before you can comment on or make changes to this bug.