Bug 135998 - yum update gives traceback after checking repositories
Summary: yum update gives traceback after checking repositories
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: yum   
(Show other bugs)
Version: 3
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-16 16:18 UTC by David Torres
Modified: 2014-01-21 22:50 UTC (History)
1 user (show)

Fixed In Version: 2.1.8-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-18 05:44:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Torres 2004-10-16 16:18:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041012
Firefox/0.10.1

Description of problem:
Trying to run yum update.  yum check-update works and gives a list to
download.  yum upgrade checks the repositories then gives an error and
goes back to prompt.


Version-Release number of selected component (if applicable):
yum-2.1.7-2

How reproducible:
Always

Steps to Reproduce:
1.type in: yum update
2.
3.
    

Actual Results:  The program gives a traceback message

Expected Results:  Yum should download and install updates

Additional info:

11:17:43 root@/ $ rpm -q yum
yum-2.1.7-2
11:17:48 root@/ $ yum update
Setting up Update Process
Setting up Repo:  development
repomd.xml                100% |=========================| 1.1 kB    00:00
Setting up Repo:  livna-stable
repomd.xml                100% |=========================|  951 B    00:00
Setting up Repo:  fedora-unstable
repomd.xml                100% |=========================|  903 B    00:00
Setting up Repo:  fedora-stable
repomd.xml                100% |=========================|  903 B    00:00
Setting up Repo:  base
repomd.xml                100% |=========================| 1.1 kB    00:00
Setting up Repo:  updates-released
Traceback (most recent call last):
  File "/usr/share/yum-cli/yummain.py", line 149, in ?
    main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 60, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 351, in doCommands
    return self.updatePkgs()
  File "/usr/share/yum-cli/cli.py", line 708, in updatePkgs
    self.doRepoSetup()
  File "/usr/share/yum-cli/cli.py", line 65, in doRepoSetup
    repo.getRepoXML()
  File "/usr/lib/python2.3/site-packages/yum/repos.py", line 454, in
getRepoXML
    result = self.get(relative=remote, local=local, copy_local=1)
  File "/usr/lib/python2.3/site-packages/yum/repos.py", line 432, in get
    checkfunc=checkfunc)
  File "/usr/lib/python2.3/site-packages/urlgrabber/mirror.py", line
414, in urlgrab
    return self._mirror_try(func, url, kw)
  File "/usr/lib/python2.3/site-packages/urlgrabber/mirror.py", line
400, in _mirror_try
    return func_ref( *(fullurl,), **kwargs )
  File "/usr/lib/python2.3/site-packages/urlgrabber/grabber.py", line
597, in urlgrab
    return self._retry(opts, retryfunc, url, filename)
  File "/usr/lib/python2.3/site-packages/urlgrabber/grabber.py", line
529, in _retry
    return apply(func, (opts,) + args, {})
  File "/usr/lib/python2.3/site-packages/urlgrabber/grabber.py", line
583, in retryfunc
    fo = URLGrabberFileObject(url, filename, opts)
  File "/usr/lib/python2.3/site-packages/urlgrabber/grabber.py", line
705, in __init__
    self._do_open()
  File "/usr/lib/python2.3/site-packages/urlgrabber/grabber.py", line
749, in _do_open
    fo, hdr = self._make_request(req, opener)
  File "/usr/lib/python2.3/site-packages/urlgrabber/grabber.py", line
832, in _make_request
    if isinstance(e.reason, TimeoutError):
AttributeError: HTTPError instance has no attribute 'reason'
11:19:50 root@/ $

Comment 1 David Torres 2004-10-17 00:54:28 UTC
problem solved by editing out the base information in the yum.conf
file in /etc/yum.conf

Comment 2 David Torres 2004-10-17 00:58:07 UTC
after editing bases section update is possible but "yum install
<filename>" does not function.  

Comment 3 Seth Vidal 2004-10-17 01:15:36 UTC
The problem wasn't solved for that reason.

You just didn't encounter a timeout.

The patch for the above has been checked into cvs.


Comment 4 Michal Jaegermann 2004-10-17 18:56:00 UTC
I got the same looking traceback, with "... no attribute 'reason'",
after trying 'yum list updates' with a default configuration file.
yum-2.1.7-2 version as well.

The second attempt got something with a bit different tail of
a traceback ending with
....
  File "/usr/lib/python2.3/site-packages/urlgrabber/keepalive.py",
line 368, in read
    s = self._rbuf + self._raw_read(amt)
  File "/usr/lib64/python2.3/httplib.py", line 409, in read
    s = self.fp.read(amt)
  File "/usr/lib64/python2.3/socket.py", line 301, in read
    data = self._sock.recv(recv_size)
socket.timeout: timed out

The third attempt succeded with expected results.

Comment 5 Seth Vidal 2004-10-17 19:30:48 UTC
It's fixed in CVS, you don't need to add anymore details.

thanks


Comment 6 Bill Nottingham 2004-10-18 05:44:24 UTC
Fixed in 2.1.8-1.


Note You need to log in before you can comment on or make changes to this bug.