Bug 13600 - AltGr key broken
AltGr key broken
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
high Severity high
: ---
: ---
Assigned To: Brent Fox
Depends On:
  Show dependency treegraph
Reported: 2000-07-08 13:28 EDT by Bernhard Rosenkraenzer
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-12-08 15:50:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bernhard Rosenkraenzer 2000-07-08 13:28:01 EDT
The AltGr key is treated like the Alt key in the "de" XkbRules setting.
This is wrong, and prevents people from using, among other things, @ 
The same is probably true for other European keyboard layouts.
beta2 was ok.
Comment 1 Stelian Pop 2000-07-19 03:57:16 EDT
I confirm, for the french layout, impossible to type a simple | (pipe symbol =
AltGr + 6).
Comment 2 Bernhard Rosenkraenzer 2000-08-01 10:31:19 EDT
The problem is with the installer, not with XFree86: It happens with XF86Config
files generated by anaconda, running Xconfigurator fixes the problem.

Comment 3 Brent Fox 2000-11-28 17:52:25 EST
I've confirmed the problem with the German keyboard that the AltGr key behaves
like the Alt key.

During the install on a French keyboard, I was able to get a pipe symbol (|) by
pressing AltGr + 6.  However, I did notice that once you disable dead keys, you
cannot reactivate them again.

Comment 4 Brent Fox 2000-12-08 15:50:40 EST
I think this is fixed in CVS.  However, I did an install using a German keyboard
with the deadkeys disabled.  Typing AltGr + Q produces an @ symbol as it
should.  I think that doing an install with the deadkeys enabled would work as
well.  Brock, please verify that this issue is resolved.
Comment 5 Aaron Brown 2000-12-15 16:35:51 EST
Verified as resolved.

Note You need to log in before you can comment on or make changes to this bug.