Bug 136001 - missing all templates
missing all templates
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mailman (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: John Dennis
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-16 12:45 EDT by Kaj J. Niemi
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-18 13:02:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
updated build patch fixing error in templates/Makefile.in (19.13 KB, patch)
2004-10-16 12:59 EDT, Kaj J. Niemi
no flags Details | Diff

  None (edit)
Description Kaj J. Niemi 2004-10-16 12:45:49 EDT
Description of problem:
mailman-2.1.5-25 is missing all templates, the directories under
/usr/lib/mailman/templates/ are now files with the content of one of
the template files. My guess is that during the rpm %install phase the
directories aren't being created before files are attempted copied there.

Version-Release number of selected component (if applicable):
mailman-2.1.5-25

How reproducible:
Always

Steps to Reproduce:
1. Compare file list from an earlier version of mailman
  
Actual results:
Most operations fail as the templates are missing.
Comment 1 Kaj J. Niemi 2004-10-16 12:59:35 EDT
Created attachment 105325 [details]
updated build patch fixing error in templates/Makefile.in

Attached is updated mailman-2.1-build.patch which fixes problem with
nonexistant template dirs. The problem was incorrect use of parameters to
install in templates/Makefile.in.

Thanks.
Comment 2 John Dennis 2004-10-18 13:02:48 EDT
Thank you very much Kaj for spotting this and providing a patch. It's
fixed in mailman-2.1.5-26 with credit to you in the spec file.
Comment 3 John Dennis 2004-10-18 13:40:22 EDT
PS: I meant to ask you Kaj, once you fixed the template problem were
you running that version of mailman on a system that was actually
serving some lists? If so is it working well for you?
Comment 4 Kaj J. Niemi 2004-10-18 13:49:56 EDT
No complaints so far.. I run this version of mailman on a server with
low volume lists for testing. 

I had to move a few of the files to new locations as described in
INSTALL.REDHAT.
Comment 5 John Dennis 2004-10-18 16:03:54 EDT
Thank you, that is good feedback. I was quite concerned that moving
the locations would break something in some unforseen way. It was
pretty well tested but I'll admit after testing I tweaked the Makefile
once more without testing and that is what you hit, which I found
emabarassing since I should know any change, no matter how small
requires another round of testing, my appologies you were hit by a
mistake of mine.
Comment 6 Kaj J. Niemi 2004-10-18 16:06:24 EDT
Hey, no problem. If you run rawhide you run rawhide, sometimes things
break and half of the fun is fixing the bugs.

Note You need to log in before you can comment on or make changes to this bug.