Bug 136006 - stopping X server leaves corrupted image on console
stopping X server leaves corrupted image on console
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-16 13:36 EDT by Florian Effenberger
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-15 11:17:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X Log File (6.22 KB, application/octet-stream)
2005-03-06 20:19 EST, Parag Warudkar
no flags Details
X Configuration File (2.75 KB, text/plain)
2005-03-06 20:20 EST, Parag Warudkar
no flags Details

  None (edit)
Description Florian Effenberger 2004-10-16 13:36:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3)
Gecko/20040913 Firefox/0.10.1

Description of problem:
Stopping the X server leaves a corrupted image on the console.

Version-Release number of selected component (if applicable):
xorg-x11-6.8.1-6

How reproducible:
Always

Steps to Reproduce:
1. Start X (xorg-x11).
2. Exit it either by menu, by Ctrl+Alt+Backspace or by killall X.
    

Actual Results:  The background image stays on the screen, with a blue
pixeled horizontally line on top of the screen, about 1/8 or 1/10 of
the screens height. No way to get back a working console or change the
console via Ctrl+F+X. SSH works though.

Expected Results:  Get back to console.

Additional info:

lspci:
01:00.0 VGA compatible controller: ATI Technologies Inc M10 NT [FireGL
Mobility T2] (rev 80)

xorg.conf:
Section "Device"
        Identifier  "Videocard0"
        Driver      "radeon"
        VendorName  "Videocard vendor"
        BoardName   "ATI FireGL Mobility T2"
EndSection
Comment 1 Parag Warudkar 2005-01-20 14:06:00 EST
This happens with X-ORG NV driver as well. I use FC3 release and I
have a Nvidia GeForce4 Go 440 card. If I use the NV driver, X works
okay, but once I leave X (while rebooting, or with init 3 or with just
exiting X) the display is totally corrupted. This is very annoying
since I am forced to use the binary NVIDIA drivers even though I don't
intend to use them and I don't require any features it provides.

It happens with 32bit as well as 64bit FC3.
Comment 2 Mike A. Harris 2005-03-06 19:09:52 EST
Update to the latest FC3 updates, and if the problem persists, please
update the bug report with status info, and attach your X server
log file, and config file.
Comment 3 Parag Warudkar 2005-03-06 20:19:55 EST
Created attachment 111724 [details]
X  Log File
Comment 4 Parag Warudkar 2005-03-06 20:20:42 EST
Created attachment 111726 [details]
X Configuration File
Comment 5 Parag Warudkar 2005-03-06 20:22:28 EST
All updates installed today. No difference - Console still corrupts 
after leaving X. Attached xorg.conf and X log file using nv driver.
Comment 6 Mike A. Harris 2005-03-07 10:00:37 EST
Parag:  This bug was filed about a Radeon video problem.  Your
problem may have similar symptoms, but it is unrelated.  Feel free
to file your own bug report however.

Comment 7 Mike A. Harris 2005-04-15 11:17:06 EDT
Since this bugzilla report was filed, there have been several
updates to xorg-x11, which may resolve this issue.  Users
who have experienced this problem are encouraged to upgrade to the
latest Fedora Core updates.

If this issue turns out to still be reproduceable in the latest
updates also, please file a bug report in the X.Org bugzilla
located at http://bugs.freedesktop.org in the "xorg" component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Setting status to "ERRATA".

Note You need to log in before you can comment on or make changes to this bug.