Bug 1360127 - during deployment getting vague message which makes troubleshooting difficult.
Summary: during deployment getting vague message which makes troubleshooting difficult.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-heat
Version: 8.0 (Liberty)
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: 10.0 (Newton)
Assignee: Thomas Hervé
QA Contact: Amit Ugol
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-26 05:27 UTC by VIKRANT
Modified: 2016-12-14 15:47 UTC (History)
8 users (show)

Fixed In Version: openstack-heat-7.0.0-2.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 15:47:02 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 346647 None None None 2016-10-14 16:52:05 UTC
Launchpad 1606148 None None None 2016-07-26 12:53:28 UTC

Description VIKRANT 2016-07-26 05:27:46 UTC
Description of problem:

Got below error during the deployment:

~~~
ERROR: 'NoneType' object has no attribute 'update'
~~~

Checked the heat-api.log file and found that error is coming from : 

~~~
>From : /usr/lib/python2.7/site-packages/heat/api/openstack/v1/stacks.py

143         environment_format.default_for_missing(env)
144         parameters = self.data.get(self.PARAM_USER_PARAMS, {})
145         env[self.PARAM_USER_PARAMS].update(parameters)
146         return env
~~~

While checking the network-environment.yml file found that issue is coming because of below empty section.

~~~
parameters:
  # Set to "br-ex" if using floating IPs on native VLAN on bridge br-ex
~~~

After removing this section deployment was successful without any issue. 

Version-Release number of selected component (if applicable):
RHEL OSP 8

How reproducible:
Everytime. 

Steps to Reproduce:
1.
2.
3.

Actual results:
It's throwing vague error.

Expected results:
It should give something more understandable. 

Additional info:

Comment 2 VIKRANT 2016-07-26 06:50:12 UTC
Upstream bug describing the same issue : 

https://bugs.launchpad.net/heat/+bug/1606148

https://review.openstack.org/#/c/346647/

Comment 3 Zane Bitter 2016-07-26 12:53:29 UTC
Fixed upstream in newton (OSP10).

Comment 7 errata-xmlrpc 2016-12-14 15:47:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.