Bug 136015 - [FHS] firefox creates files not tracked by RPM in /usr/lib/firefox-0.10.1/chrome/, others
Summary: [FHS] firefox creates files not tracked by RPM in /usr/lib/firefox-0.10.1/chr...
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-16 20:15 UTC by Daniel Reed
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-28 08:05:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
list of all files in /usr/lib/firefox-0.10.1/ that are in neither rpmdb nor rpmdb-fedora (1.83 KB, text/plain)
2004-10-16 21:13 UTC, Daniel Reed
no flags Details

Description Daniel Reed 2004-10-16 20:15:08 UTC
User-Agent:       
Build Identifier: 

After an installation of Fedora Core rawhide, an unknown process modifies files
in the path ``/usr/lib/firefox-0.10.1/chrome/'' and others under the path
``/usr/lib/firefox-0.10.1/''.

``/usr/lib/firefox-0.10.1/chrome/'' is owned by the package ``firefox''.


http://www.pathname.com/fhs/pub/fhs-2.3.html#THEUSRHIERARCHY

``/usr is the second major section of the filesystem. /usr is shareable,
read-only data. That means that /usr should be shareable between various
FHS-compliant hosts and must not be written to. Any information that is
host-specific or varies with time is stored elsewhere.''

http://www.pathname.com/fhs/pub/fhs-2.3.html#USRLIBLIBRARIESFORPROGRAMMINGANDPA

``/usr/lib includes object files, libraries, and internal binaries that are not
intended to be executed directly by users or shell scripts.''



The files in these various hierarchies do not appear to be object files,
libraries, nor internal binaries, but data files. They also do not appear to
have been updated except during package management. However, they are not
tracked by package management as they were [apparently] generated at install
time and left unassociated with the package they were generated by. If the data
can not or should not be generated on the fly, it may be best suited for storage
in the ``/var/cache'' hierarchy.

http://www.pathname.com/fhs/pub/fhs-2.3.html#VARCACHEAPPLICATIONCACHEDATA

``/var/cache is intended for cached data from applications. Such data is locally
generated as a result of time-consuming I/O or calculation. The application must
be able to regenerate or restore the data. Unlike /var/spool, the cached files
can be deleted without data loss. The data must remain valid between invocations
of the application and rebooting the system.''

Reproducible: Always
Steps to Reproduce:

Comment 1 Daniel Reed 2004-10-16 21:13:35 UTC
Created attachment 105328 [details]
list of all files in /usr/lib/firefox-0.10.1/ that are in neither rpmdb nor rpmdb-fedora

Comment 2 Christopher Aillon 2005-03-28 08:05:20 UTC
Should be fixed in rawhide.


Note You need to log in before you can comment on or make changes to this bug.