Bug 1360259 - ltrace: Crash when run on certain processes with the -S option
Summary: ltrace: Crash when run on certain processes with the -S option
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ltrace
Version: 7.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: DJ Delorie
QA Contact: Martin Cermak
URL:
Whiteboard:
Depends On:
Blocks: 1420851 1473733 1477664 1678260 1710255 1731204 1731211 1734363
TreeView+ depends on / blocked
 
Reported: 2016-07-26 11:20 UTC by Jan Zarsky
Modified: 2020-03-31 19:58 UTC (History)
12 users (show)

Fixed In Version: ltrace-0.7.91-16.el7
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1678260 (view as bug list)
Environment:
Last Closed: 2020-03-31 19:57:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1089 None None None 2020-03-31 19:58:00 UTC

Description Jan Zarsky 2016-07-26 11:20:53 UTC
Description of problem:
When run on certain processes (e.g. dbus) and with the -S option (show system calls), ltrace crashes and kills traced process.

Version-Release number of selected component (if applicable):
ltrace-0.7.91-14.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1. Get PID of dbus, auditd or rsyslogd (just examples)
   # ps -ef | grep -E ^dbus

2. Run ltrace with the -S option
   # ltrace -p <PID> -S

Actual results:
# ps -ef | grep -E ^dbus
dbus     28044     1  0 06:50 ?        00:00:00 /bin/dbus-daemon --system --address=systemd: --nofork --nopidfile --systemd-activation
# ltrace -S -p 28044
getegid32@SYS(ltrace: fetch.c:287: allocate_integer: Assertion `!"Too many return value classes."' failed.
Aborted
# ps -ef | grep -E ^dbus
#

Comment 20 DJ Delorie 2019-07-24 03:39:47 UTC
Fixed in ltrace-0.7.91-16.el7

Comment 25 errata-xmlrpc 2020-03-31 19:57:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1089


Note You need to log in before you can comment on or make changes to this bug.